Macosx. Monterey Mail extension

Duh. How stupid of me to overlook that when I’ve done it countless times over the years. Thanks @rmschne. Works now.

I am using an M1 Air with Monterey 12.2, only recently installed Devothink, and the Mail App does not even mention plug-ins. Devonthink needs to switch over to an extension, and I think many of these issues would vanish. As it stands, I cannot use it.

Have you installed from the DEVONthink menu this extensions?

I have installed the Apple Mail plugin from DT. There is no Apple Mail extension. This is also borne out by the fact my Mail application shows no DT extensions, and in fact, shows no extensions.

ok. one other question. have you done what has been suggested here already, eg Mail Add-On not working

Yes. I have done as follows:

  • I have given DT3 access to the entire disk
  • I have shut down both Mail and DT3
  • I have gone to Library/Mail and I removed a Big Sur plugin
  • I have restarted DT3
  • I have gone into DT3 Install Add-Ons, deselected the Apple Mail Plugin, which was still selected
  • I emptied the cache in DT3
  • I have gone into DT3 Install Add-Ons, and… wait a sec, it now says Apple Mail Plug-Ins is installed
  • I have started Mail, gone to Preferences:General, and the is now a Manage Plug-Ins for the first time
  • And now it works like a champ

I am using M1 MacBook Air, Monterey 12.2, DT3 3.8.1

This was essentially a fresh install, since I installed a few weeks ago onto this machine, so didn’t bring anything from a different OS version. Notes that I had tried the same instructions earlier, like less than an hour ago, and it didn’t work. I am kind of thinking that the DevonThink3: Empty Cache could have done the trick.

Anyhow, its working now!


List item


Welcome @jbntxdev

And glad to hear it’s working now.

Thanks, @BLUEFROG, and thank you for your guidance!

You’re welcome :slight_smile:

I have done all of the steps @jbntxdev mentioned, but I’m still getting the “Incompatible Mail Plug-ins Disabled” error.

Here is a little background on my situation. The plugin was working on my Intel MacBook Pro 2018 before I migrated to a M1 MacBook Pro 2021 with Monterey 12.2.1, Mail 15.0 (3693., and DT3 3.8.2. I was running the same versions on my old computer.

Any thoughts, @BLUEFROG?

Welcome @j-x-d

Hold the Option key and choose Help > Report bug to start a support ticket.

1 Like

M1 MacBook Air, Monterey 12.3 | DevonThink 3.8.3 | Apple Mail Plugin 4.0.6

  1. given DT3 access to the entire disk
  2. shut down both Mail and DT3
  3. gone to Library/Mail and I removed a Big Sur plugin
  4. restarted DT3
  5. emptied the cache in DT3
  6. gone into DT3 Install Add-Ons
  7. Opened Apple Mail
  8. Apple Mail - Preference - Extensions - empty. No DevonThink extension.

Correct because we have no extension. This has been discussed here before and we have never mentioned or called it an extension. It’s a plugin.
It is enabled in Apple Mail’s Preferences > General > Manage Plug-Ins.

“Preferences > General > Manage Plug-Ins.”


Thank you.

No worries and you’re welcome.

I just want to thank you for the workaround. Same problem, same solution! It also works on an all new Mac Studio in June 2022 and, by the way, the plugin that works is still the BigSur one…