Rules no longer working – any suggestions?

Hello all,

I know this is most likely a problem – but since (a.) it’s effecting my use of DTPO – and more importantly – (b.) the people that hang out here are far more knowledgeable and quick to assist, unlike the behemoth that is the Apple Support Communities, I figured I would try my luck.

All appears to have stopped working on 21 January 2015, since that is the latest date of the applicable email in the applicable Smart Folder.

What I did before/am doing currently:

1.) Any email I want to find its way into DTPO – I used a shortcut to expand the term "DTPO Inbox:-- " either at the beginning, or end, of the email’s subject line.

2.) Over in, I have a Smart Folder with the following conditions:

Smart Mailbox Name: DTPO Inbox:-- 
Contains messages that match [all] of the following conditions:
[Subject] [contains] [DTPO Inbox:--]

The above is purely for me to ‘keep tabs’ on what should be sent over to DTPO, and is a useful reference point to jump into, to confirm what was recently so-sent.
The latest email, sorted by date – as mentioned – is 21 January.
This is clearly wrong, since I’ve sent plenty more since then – somewhere, something is going haywire since it’s not picking up those emails with “DTPO Inbox:–” inside the subject line.
I have deleted the smart mailbox, re-created it, selected “rebuild” in the menu option – nothing changes.

3.) I have an rule that is as follows:

Description: To Devonthink
If [any] of the following conditions are met:
[Subject] [contains] [DTPO Inbox:-- ]
Perform the following actions:
[Run AppleScript] [Mail Rule – Add messages to DEVONthink Pro]

The latter AppleScript being presumably from the plugin, installed through DTPO.

So, on the one hand, the Smart mailbox isn’t working – and similarly, the rule, which is following the same recipe, is NOT firing either (or at least, not since 21 January 2015)…

Any suggestions?


I would start with a Mailbox > Rebuild in

Thanks Jim – tried that right at the beginning this morning >> no go.

It’s a bit odd – or have I finally been hit by one of’s Mavericks/Yosemite (alleged) quirks… I suspect not – more likely something I’m doing. But I’m not finding anything obvious.

It was also a bit of a reminder to people that an occasional Mailbox Rebuild isn’t a bad thing to do. :smiley:

Sadly, Mail Rules have always been finicky (just as Folder Actions in the Finder can be). Have you tried editing the Rule (add and remove something to it) and then let it apply the Rule again?