Mail Archiving fails


A few days ago I wiped my Macbook Air and reinstalled OSX 10.8, all fully up to date. I then installed DEVONagent Pro and DEVONthink Pro Office, both of which had worked perfectly (with the exception of DTTG) on the same machine that morning.

After I was putting the settings on the apps back the way I liked them I found a problem in the DEVONagen mail settings, which I itemised in the DEVONagent forum at
DEVONagent Pro - Preferences|Mail.

Today, I went to archive my email from Apple Mail into DEVONthink, as I have done many times, but this time, the first time I have tried it since the fresh install, I got an error message;

	“Couldn’t Access mail in Apple Mail
	Please check if you are using the latest version of your mail program”

Well, I am. I am using the latest everything for OSX, DEVONagent and DEVONthink, including the Apple Mail plugin and Apple Mail Rule scripts and yet both programs have baulked, and both at Mail related items.

Is anyone else seeing this on fresh installs?
Am I wrong to think that the fact that both DEVONtechnologies programs are showing Mail related anomalies is not just a coincidence?

ps. Since the rebuild, DTTG works perfectly and is blisteringly fast. Every cloud and all that…