Mail Plugin not installed but I can not reinstall it from Devonthink (pro)

Mac Montery,
the mail plugin library in the library folder is empty and therefor I can not activate it.
Devonthink has access to the drive.
In Devonthink the program says that the plugin is installed (checkbox is grey), but it is not.

How can I reinstall the mail plugin?

Werner

Welcome @wmueller

To ensure proper the Apple Mail plugin is installed and enabled correctly, do this…

  1. Quit Mail.
  2. Quit DEVONthink 3.
  3. Enable Full disk access and all Automation requests for DEVONthink 3 in System Preferences > Security & Privacy > Privacy.
  4. In the Finder, hold the Option key and choose Go > Library.
  5. Go into the Mail/Bundles folder and delete our mailbundle.
  6. Relaunch DEVONthink 3 and install the Mail plugin from DEVONthink 3 > Install Add-Ons.
  7. Relaunch Mail and enable the plugin via Apple Mail’s Preferences > General > Manage Plug-ins.

I can delete the mail plugin.
I can then add a new mail plugin from DEVONthink 3.
In Mail I can not see in the preferences the Mail Plugin.
The name of the mail bundle is DEVONthink_BigSur.mailbundle
I am using MacOS Monterey.

The name of the mailbundle is inconsequential. It refers to a division of the operating system where the internals differed based on changes made by Apple.

Is your home directory on the internal boot drive or an external drive?

It is on the internal boot drive.

I am having the same issue.

Steps 1 through 3 are fine but the is a difference with step 4

if I go to Library the Mail folder with the DT3 bundle is not there. It is in ~/Library/Mail though and when I delete it and start DT3 it does place it back in that same location.

It does not appear in the apple mail settings extensions tab though.

my home directory is on the internal drive of my M1 MacBook directly under /users

I am running Ventura 13.2 and DT3.8.7

I have reinstalled both and tried the instruction sequence again but still get the same result. Bundle installs in Library/Mail under my home directory not in /Library and apple mail sees no extensions

Thanks for your help
Chris

Hold the Option key and choose Help > Report bug to start a support ticket.

Thanks - ticket raised

Same here.
Also running Ventura 13.2 and DT3.8.7

Same here…

Post a screen capture of what you’re looking at in Mail.

Due to Devonthink the Plugin is installed, but the “Erweiterungen” Window in Mail is empty.


The plugin is to be activated in the General tab (Allgemein), afaik

2 Likes

It is activated…

There will be nothing related to DEVONthink in the Extensions pane as we do not have an extension.
@chrillek is correct and your screen catpure shows the plugin is installed and enabled.

You should now file Add to DEVONthink 3 commands in the Mailbox and Messages menus in Apple Mail.

1 Like

Thank you for your help! I had misunderstood this. No it works fine!

You’re welcome.