Markdown - continue editing?


I’m in a habit to use basic text as much as possible. So in any DTPO database, I would rightclick and select new > plain text
Lately I’ve started using markdown more and more. What I find today is that when I rightclick > new markdown and then later on want to add additional writing to the same document, that I can not edit it anymore?

What am I missing?
How can I continue editing the same markdown document in DTPO?

As always: Thanks for helping out!

Depending on the preferences (see Preferences > Media) the preview might be shown by default which isn’t editable. Changing the preferences or switching to the other view (see e.g. View menu or navigation bar) should make it editable again.

Thanks a lot! I was not aware of this setting, and would definitely not seek it under Media :wink:
Would you mind explaining what is the reasoning to not make it editable by default, or why build in the option to disable editing at all?
What’s the difference with *.txt?

Thanks for helping out!

Previews are never editable, they’re not indended to disable editing but to preview the Markdown document.

Hmm, I understand, but then why is the txt ‘preview’ editable in line? Where do I miss the logic?

Which preview is editable? A screenshot might be useful.

Would you mind explaining what is the reasoning to not make it editable by default, or why build in the option to disable editing at all?

Because many people want to see the rendered output when they select a Markdown file.
And that’s what the preference is for: so you can choose whether to view or edit a newly selected Markdown file.

What I mean here, is that I would simply rightclick in the upper righthand pane, create an md document, write the name or whatever, then switch to the bottom righthand pane and continue writing my list or text. Without the setting in the Media pane as previously mentioned this does not work.

Anyway, problem solved!
Thanks a lot!

New or empty Markdown documents are always opened in Edit mode as there’s nothing to preview yet anyway.

1 Like

Could I ask a loosely related question? I noticed my markdown files are rendering in DT3 with a font that looks like Times Roman or something similar. I was under the impression that if you didn’t select a specific stylesheet in preferences that the font would render what was specified for rich and plain text editing in preferences. I don’t have any stylesheets specified, and my plain and rich text editing font is the system default. Is that understanding correct?

The default rich text font should be used. Screenshots of Preferences > Editing and Preferences > Media would be useful, thanks.

Here’s the preferences. Is this correct?

This is correct.

Was the rich text & note font selected by you?
If I hold the Option key and press Reset, the font resets to Times Roman 12.