Markdown frozen with menu in rendered mode

This has happened a few times in the last week or so. I was trying to see if I could force it to happen but haven’t had any luck so far. It seems pretty random.
I use a shortcut to create and pre-populate a markdown file for a daily journal. Recently its been opening DTTG in this weird state of showing the rendered markdown but with the text edit menu showing. The “x” in the top right doesn’t respond and there’s no way to back out to the containing group. The only thing thats worked it to completely quit DTTG (whatever that iOS thing is when you remove it from the list of running apps)

[edit] fully updated XR/iOS 15

DEVONtech generally ask that for freezes you should open a support ticket. If you do that via the app itself (by tapping on of the ? > Contact Us at the bottom of the main DTTG screen) the email will include the necessary logs.

Have you rebooted this device recently?

I have rebooted recently. I am a frequent rebooter.
Next time I will try to do the report via the app.


I have these freezes as well, occasionally and so far with no idea about a pattern to report.

  • What version of DEVONthink To Go are you running?

  • Do you have files linked in the document, including images or file transclusions?

Nothing such fancy - I am taking notes when it happens, simple Markdown notes (always on the latest version). I think it happens when I switch apps and return or do something to the menus. I need to watch it and will report. I have not lost anything, even if I was in the middle of writing, so I had no problems quitting the app and start over. I’ll let you know if and when I can recollect what happened.

This just happened again. I have sent logs etc via the email support channel. (#424787)

This time I tried a few more things to break the freeze before force quitting.
From the bottom left … menu:

  • Update Preview - nothing changes
  • Group - puts current frozen doc in a new group of same name, puts viewer in group hierarchy, open doc in its new group, everything is there, no longer frozen.

I also just got a frozen state: the preview of a markdown file is shown, while the cross to exit the edit mode is still there and I am not able to leave editing the document. I have to quit the app to continue.

This still happens from time to time. Never had any data loss but it requires restarting the app.
One thing I just noticed was that this time I was in markdown edit mode on my phone, I turned my phone sideways to landscape, the screen was empty although you could see the shadings for the two column view and when I turned it back to portrait, the doc was showing the rendered version of the doc but with the editing menu still visible. Hitting the X or trying to exit the doc didn’t work.

Updated to most recent DTTG app version and rebooted before this instance.
Theres one more iOS 15 version update to do or just skip to 16.

Are you seeing this issue in the 3.6 release?

I did. I had updated DTTG recently. I remember seeing the update notes yesterday morning.

Last night I updated iOS to 16.1 or whatever is latest.
Will track if I see this again. It was very occasional before so…

I did a test this morning that switching screen orientation (portrait to landscape)changes edit mode to render mode. But it worked smoothly with no rogue edit menu.