Markups/Annotations disappear while working. Due to iCloud-sync?

Hi there!

Just got a licence for DT3 and DTTG and will use it for my PhD. Immediately ran into a major issue that halts everything. Have tried (to my ability) finding answers here but not found any relevant to DT3. Hoping that posting a new topic can help me! :slight_smile:

I have an indexed DB, with files stored in a local iCloud Drive folder (to sync and also use DTTG).

On my laptop, to work with a PDF, I double click it to get a reading window. I markup and make annotations there (it allows me to simultaneously look at the reference list of the article).

However, after having made som markups, I see those marksups disappear from the main window. They remain in the separate window as long as I have that open. Then, when closing that, all markups and annotations are gone.

Does this happens as DT3 syncs with iCloud? Or is there a setting I need to change?

As DT3 behaves now it will be impossible to work with it. And I haven’t experienced this before, when running indexed DB’s on prior versions of DT a few years ago.

Maybe I should contact support directly, but it seems the modus operandi is to start with the community. Hope you can help! :slight_smile:

Screenshot of mismatch between windows:

In case of indexed files located in cloud folders (in this case iCloud Drive) DEVONthink’s sync doesn’t synchronize the files (only the internal metadata/index like name, URL etc.) to avoid conflicts, therefore it’s up to the iCloud sync to synchronize the files in iCloud Drive.

Are the files in iCloud Drive always locally available? Did you edit/open them on multiple devices? Finally, which version of macOS and DEVONthink do you use?

Hi @cgrunenberg, thanks for replying!

So, first, the specs:

  • OS Sonoma 14.0 on a MacBook Pro from 2019.
  • DT3 3.9.3.

Yes, the files are always available locally. I only manage them trough the folders on my MacBook, not on the cloud directly. And I edited/opened them only on the MacBook.

I reestarted DT now that I got to the office and tried with a priorly indexed file, the behaviour was the same. However, I’ve done some experimenting, and the software is behaving quite inconsequently.

To exemplify: I tried marking up in both windows (original and having double clicked the pdf). At first try, markups made in the main window did not show in new window, and when making new markups in the new window, the first ones made in the main window would disappear, leaving only the new ones. They would then all disappear from the main window after some 15-30 seconds, leaving me with a second window with markups that I know will be gone as soon as I close that window (e.g. no effect from hitting save in that window).

However, trying to reproduce that scenario, suddenly all markups and comments seemed to remain, regardless of my behaviour.

But alas, continuing my trials, the mismatch reappears.

My best guess is that there is something about the interplay between me hitting save and the “sync” of the changes made.

Is there a conflict between the two windows / views? Is DT treating it as two instances, and they conflict, having one overwrite the other? (when saving or when “syncing”/updating changes in either window).

I’m really sorry to be giving you this confusing information. How can I help make sense of what might be going on?

I’m attaching a screen dump of my DB-settings, which I think are default.


Hi again @cgrunenberg!

Some added info that might be helpful.

I did some markups and annotations now in the main window (restarted DT3 first), without double clicking and opening the pdf in a new window. Then pressed save, and updated the database, but saw no changes to the file in Finder. Waited a while to see if time was a factor, but didn’t seem so. I then closed DT3 and reopened it, and all markups and annotations were gone from the pdf.

Maybe I’m behaving irrationally in some way that I don’t grasp (completely open to me being the problem), or there is something else going on …

Anyway, looking forward to your advice.


While it’s possible to view/open a document in multiple windows, it should be only modified in one. The other windows get updated after saving.

But overall there might be indeed something else going on (e.g. an unknown Sonoma issue), therefore please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

1 Like

I’ve had a very similar issue (see my short separate thread). Just thought I’d confirm here. I am also running Sonoma 14.0 and will update this to see if it makes any difference.

I would highly recommend to update, 14.0 was quite buggy (and even 14.1.1 still is).