Metadata after OCR in DT3b3

When the metadata field opens after OCR in DT3b3, the title field entry is not retained when saving the document into the database. The text I find in the “Title” field is some other text from the scanned document.
I have properly activated the “enter metadata aftertax recognition” in the preference panel.
Is this a beta-related quirk or did I do something wrong?
P.S. it works alright in DT2 and did work in DT3b2.

Please provide more information, like what scanner you’re using and whether this is input from an external scanning application or File > Import > Images (with OCR), etc.

Jim, here is the routine:

  1. Scan through ScanSnap Home (set to insert Scan date > NO OCR>send to DT3)
  2. Choose DT3 database folder
  3. OCR in DT3>insert Metadata
  4. Panel shows up with scan date as title (provided by ScanSnap Home)
  5. Sent to chosen database folder
  6. Shows up in folder w/o scan date and “some” text from document

So, what happens? Again this works alright in DT2 and it it previously in DT3b2. Something changed…

I experience the same thing with the same equipment and settings.
I actually found it kind of cool that the name of the document became first few words of the OCRed document.

Was there any message in the log window?

No, nothing shows up in the log. The entry for metadata is just ignored!

Are you scanning documents or receipts or ?

I am scanning everything as"documents"

I’ve encountered the same problem as rundeg. Here are the steps to reproduce:

  1. I’m using a ScanSnap S500M.

  2. In ScanSnap Manager, I’m using these settings:

Application tab: DEVONThink 3
Save tab: saving to /~/Pictures
Custom File Name (I head it with the date the document was created and add identifying text).
Serial Number: 0 digit.
Rename File After Scanning: NOT selected
Scanning tab: I’ve tried several Image Quality settings; it has no effect on the replacement of the file name in DEVONThink3.
Blank Page Removal: selected
Continue scanning after last page: selected
File Option tab: PDF file format
Select OCR options are NOT selected.
PDF File Format Option: Multipage PDF.

When I scan the document, the file that is produced has the Custom file name I entered.

Then it goes into DEVONThink3 where I have these settings in Preferences > OCR:

Convert Incoming Scans: To Searchable PDF.
Original Document: Move to Trash
Searchable PDF: Enter Metadata After Text Recognized (I’ve tried selecting and deselecting it; I get the same result either way).
Custom Dictionary: Deselected
Primary Language: English
Secondary Languages: French, German, Italian, Latin

When the file gets into DEVONThink3, a series of messages appears in a temporary text box at the bottom of the sidebar. Something like:
“[My Custom Filename]”
Loading Document
Analysing Document (page 1 of 2)
Synthesizing Document
But the whole time “[My Custom Filename]” is displayed.
If I do have “Enter Metadata After Text Recognized” selected, the dialog box for entering metadata still shows “[My Custom Filename]” in the Title field.

However, once the Import process is over, the file that appears in the list has an entirely new name, using the first few words of the new document.

The really weird thing is, I could swear that the last time I scanned documents a few days ago, this was not happening.

Was ScanSnap Manager recently updated?
ScanSnap Home had an update on July 2.

It was indeed updated, but I do not think this has anything to do with ScanSnap.
It happens when I enter Metadata in DT3b3 that is not accepted. Same procedure as VictorGav.

Are you running any smart rules?

No Jim, I am not. It’s all very straightforward.

My ScanSnap software was last updated in 2018 (version 6.3 L70), because my ScanSnap is old and I don’t think any later software will work with it.

Also, no rules here.

Strange. We aren’t seeing any such issue here.

Does this persist after rebooting the machine?

I will try tomorrow morning and report back!

I’m having same issue using ExactScanPro and an fi-7160. ExactScan names the file with the creation date which shows up in DT3b3 metadata dialog box. I then add additional text which doesn’t show up/ignored when I save and the file name becomes the first few words of OCR’d text. If I scan into DTP2, I can edit the metadata and it “sticks”.

Welcome @Sevo2300

Can you post a screencap of the Metadata panel showing the incoming filename and your additional text, then a screencap of what the resulting filename is?

I just rebooted and the problem persists, alas.