Move files into database and stop indexing group

I have an indexed group that I am trying to move into my database. I selected all of the files and chose ‘Move into database’ – but the folder itself still seems to be stuck as an indexed folder. The path of the files I moved into the database also still point to the external folder. I cannot see an option for ‘Move into database’ when I select the group and I cannot find any information about how to stop a group from indexing. Even though I moved all the indexed files that were in the database into the database, the groups that held the files still show up in a smart group looking for indexed items.

How do I remove all indexing from a database and move everything into the database, without losing the tags on the groups and files?

Selecting the enclosing indexed folder and choosing Move into database should be sufficient. Of course the indexed files have to be locally available (e.g. in case of cloud folders or network volumes) for this operation.

That does not seem to be working. I don’t see that option when I select the indexed folder (see screenshot) – but you can see from the screenshot that the icon for indexing is there. In addition, all of the files in the folder still have the indexed icon, but I have selected them all and used ‘move into database’.

I also know the groups are indexed because they are appearing in a smart group to find indexed groups:

Do I need to use the ‘Move to’ option and select the database I want to move them to? I am not sure if this actually moves the group into the database (i.e., turns off indexing) or just moves the indexed group around in the database.

Also, I checked and the files are all locally available.

Not all commands are available in the already very large contextual menu of the sidebar. But the contextual menu of the main view supports.