Move into Database not working as expected across 2 mac syncing - behaves unreliably

Set up:

  • Syncing a DTP DB via DT using WebDAV Server location
  • Sync via DT and use the DB on a desktop mac (A) and laptop (B)
  • Have a folder on the desktop of mac A that I index into the DB
  • upon syncing DT on mac B, the folder and files appear of the desktop and within the DB, as expected > the files are in the DB on both macs and the folder (with the files) appear on the desktops of both Macs

Issues occur when selecting the indexed folder in the DB and selecting “Move Into Database” on mac A and then after DT synsc the DB:

  1. on mac A

    • the files move into the DB but the folder does not and DT throws an error “Folder is not empty” and the folder remains on the desktop of the mac A.
    • the folder still shows as indexed in the DB on mac B and using the move in command again yields no change leaving the folder on the desktop and showing as indexed in the DB
    • If I move the files to a new group in the DB (for safety) and delete the Desktop folder, using the “Show in Finder” command on the DB folder that erroneously shows as indexed in the DB opens the Desktop folder in the finder - but of course there is no folder there, (Yes I tried the Update Items command)
    • Also sometimes files in subfolders of the indexed folder and the subfolder are not moved into the D, either.
  2. After the DB syncs to mac B:

    • the desktop folder remains on the the desktop of mac B
    • Some but not all of the files / sub folder / or its files move into the DB
    • similar behavior as what occurs on mac A - files remaining on the desktop and DT sync errors

Suggestions for correcting - or have a missed something in the expected behavior?

Is your Trash empty?

Sometimes yes, and sometimes no. The behavior explain has appeared to be independent of whether or not anything is in the trash.

Hi - I Haven’t heard back on this issue.

Historically responses have quick, but I’ve not heard back on a different previously posted issue. Are you all changing how you support and respond to the forum?

We have more than one support channel, our primary one being our support ticket system. Nothing changed, though our Lead Developer was also on a well-deserved holiday all last week.

Just bumping this topic.

The issue still occurs and results in tedious file by file manual checking - any suggestions for remedies ?

Is the indexed desktop folder synchronized via iCloud Drive too?

Nope - I do not sync desktop files with iCloud.
And for more info - using the DT facility to move index files into the database frequently leaves remnants (folders and files) in the original location, regardless if the location is on the desktop or on a local drive.

Even without synchronizing?


Are you able to always reproduce this? In that case a screenshot of the Finder hierarchy and the DEVONthink hierarchy before & after moving the file/folder into the database would be useful as I don’t experience these issues (although I use this functionality frequently). Thank you!

Typically haven’t done a precise test to reproduce so I just tried.

Just tried to reproduce:

  • desktop with indexed files and then moved in - acted normal
  • same with sync to laptop – get error

see the screen shots
Screenshots.pdf (2.7 MB)

On the laptop please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!