Moving file from Inbox to an indexed folder

Up until recently, if I moved a file from one of my inboxes into one of my indexed folders (say “Folder A” in “Database 1”):

  1. the file moved from the inbox to indexed Folder A in Database 1 in DEVONthink
  2. the file moved to indexed Folder A in Finder
  3. the file is now indexed

Now, if I move the file:

  1. the file moves from inbox to indexed Folder A in Database 1 in DEVONthink
  2. the file does NOT move to the indexed Folder A in Finder, but rather is moved to Database 1
  3. the file is NOT indexed

I’m not sure what’s changed (updated to version 3.9.1?). Any help to figure out why the change in behavior and what I might to to get back to the original behavior.

P.S. Under the second scenario, I can use the “Move to External Folder” feature (as step 4) to achieve the desired result but that’s just one more step.

Is anything logged to Windows > Log? Where are the indexed files located in the filesystem?

Nothing logged in Windows > Log.

The post-move indexed file is located here:

Update: It appears that the “old” behavior is the same when moving a file from within the same database’s inbox to the indexed folder. So the “new” behavior is limited to moving a file from the Global Inbox or one of my many other databases.

@cgrunenberg: I have reproduced this here, moving an imported file in the Global Inbox into a newly indexed group in another database.

CleanShot 2023-06-07 at 10.47.24@2x

This is a Finder folder I know has never been indexed in another database.

And no hidden preference is set:

And @rjudice: yes, you should still have the Move To External Folder command available and useful.

Fixed for the next release.


I’m seeing this behavior in DevonThink 3.9.4 when I move a file using option-drag. (The behavior I want is for the native file in the source DB to be moved to the filesystem in the (indexed) destination DB; as a workaround I can certainly move the files direct into the filesystem, but…it should work when doing this within DT natively.)

EDIT: never mind, the problem was in the interface between the chair and the keyboard

1 Like

Good to know - cheers!