my DTTG don´t synch my data

My configuration:

  1. Devon Think pro office 2.06 on my Powerbook pro
  2. DTTG on my iPad

a) I start my DT pro on my Powerbook
…have some data files in my "sync-group
b) I start my DTTG on my iPad
… both Powerbook and iPad are connected in the same WiFi Network
c) I press the synch-button in DTTG
d) a message appears: Please chooce your Mac in your local network… and my “Powerbook” ist listed.
e) I click on the “Powerbook”, BUT NOTHING WORKS: The window with “Please chooce…” remains on screan. I only can press “cancel”

Sometimes the connect between my Powerbook and my iPad breaks - then the system demands me to put in a Pin. I write the PIN in my iPad - but although after this - a synch does´nt work;-(
Please help me!

We are working on a new release that focuses mainly on sync improvements. This will not cure network-related issues. A number of posters to the Forum have had issues that were resolved by changing their firewall settings or other network configuration details. Please try these steps to see if you have a network issue:

Make sure that your Mac firewalls have an exception set for your DT desktop product (in System Preferences, go to the Security icon, select the Firewall tab, click ‘Advanced’, and add your DT desktop product to the list of “allowed” applications). If that fails, then try creating a “private network,” go to the Airport icon in the menu bar (or in System Preferences, Network) and choose “Create Network…”. This allows you to create a network just using the WiFi on your Mac. Create a network and see if you can sync your device over this ‘private’ network. If this works, it means that your WiFi router is either dropping a fair number of packets when communicating between your device and the Mac or the WiFi router is blocking our protocol. It should be noted that we use our own protocol for communicating between the desktop product and your iOS device. While more secure, it is also somewhat less robust than higher-level protocols like HTTP when it comes to dealing with dropped packets. And while known protocols like HTTP or FTP are “understood” by WiFi routers, if security features are set to ‘high’ on some routers, they may see our protocol as being suspicious and block it. In any event, please try the above steps and let us know if they have any effect. If the “Create network” approach works, then you might need to look at your WiFi router’s settings to see if there is something blocking our traffic. In any event, let us know what you find after trying one or both of these approaches.

I too have had sync problems which I have reported in a support ticket.

And I too have found that a ‘Private Network’ does indeed fix all my sync issues. But this also stops wi-fi internet traffic, so this only works for diagnostics or emergencies.

I’ve so far spent a quite few hours setting up DTTG and sending in emails to DT support with details of my sync tests so far. I don’t think I can waste any more time on this; neither do I have the tech skills to examine my wi-fi router’s settings.

In fact wi-fi on my iPad works perfectly for all other usages: all internet traffic, and wi-fi sync of Things and Air Sharing are all reliable and fault free.

So I must admit that Mike’s helpful explanation of wi-fi protocol just makes me think that ‘more secure than HTTP but less robust’ was a bad choice for DTTG version 1!

And I certainly don’t envy Mike’s task in fixing these problems!

Thank you for the words of support. We are working on a release now that should resolve some of the problems with sync, but it appears that issues related to WiFi networks outright blocking our protocol will not be addressed until a later release. All I can say is that we had a really long beta test cycle and did not find anyone who encountered these syncing issues. Looks like we need a more varied pool of beta testers for our next major release. We appreciate your understanding as these issues are sorted out and resolved in upcoming releases.

Thanks for all, BUT …

  1. I am not a http/ftp/router/network …-expert;-(
  2. All other Ipad-apps works very well
  3. I am just a little disappointed about DTTG (not about your support;)
  4. …and hope, this “malfunction” will be fixed soon with the next update.

I’m curious, the reference above of a new version being worked on - what is/was the current version of DTTG before this new version.

I have 1.0.2. I had all my “sync” files from the mac on my iPad - i.e. syncing had worked well a few weeks ago. Today, I’ve been going through all my sync-able apps to test everything out and found that DTTG no long synced (just as reported by other posters). I don’t have the firewall on. When I click the sync icon on DTTG, my macbook pro is not listed. I followed earlier directions by resetting DTTG from the settings app). Then the mbp’s name did appear, but when I clicked on it, it went blue but nothing happened. I closed DTTG (really closed it) and invoked again. Now I can’t even get my mbp to appear in the computer list when trying to sync. Reset no longer does anything.

I tried the “create network” trick but that didn’t work. (My mbp has been wired; not using wifi. But I also tried invoking wifi, using the normal router, a relatively new Airport Extreme, didn’t work. As I said, the local network route didn’t work either.) At this point, DTTG has lost the previously synced files.

Well - here’s the kicker. While I’ve been writing this (a number of minutes), I’ve had the DTTG sync window open, but doing nothing. Now, all of a sudden, my mbp’s name appeared, I clicked it, and I got the sync code screen to display. I entered the code from the desktop DT and DTTG proceeded to sync. Once done, I clicked the synchronize button again, got the mbp button but pressing it a number of times, nothing happened. Eventually, clicking it started the sync process (this time I added a database to the checked ones to see if it would add more files to DTTG - all went well.

It seems that sync connections are haphazard at best. Before I sign off, I’ll try one more thing - removing some files in the sync folder on the laptop and then sync to DTTG, to see if those files are removed on the iPad… YES, it all worked (although, again, I had to press the mbp’s button several times before it took.

(Well, I shouldn’t have done it, but I just tried one more sync - the mbp’s button appears in the computer list, but pressing it turns it blue as long as my finger is on the button, but try as I may, I can’t get the sync going.)

And that is my report to the forum!

What we are noting is that since the release of iOS 4.2.1, users of DTTG on the iPad are having significant issues syncing with the desktop product. Some users note that the other ‘sync’ apps (using WiFi to a desktop, not cloud syncing or USB syncing) are exhibiting similar issues. This would not be notable except that a number of users report that all worked fine until they upgraded to 4.2.1. We have built the latest release (1.0.2) to support 4.2.1 and we have tested it on a number of iPads before release without noticing any (new) problems. For iPhone users who had good sync experiences prior to the iOS 4.2.1 release, they generally report no difference after the OS upgrade.
I am elaborating on all this to the list as we are trying to characterize the problems our users are finding in the field. Granted, a number of users have had issues with syncing since the 1.0 release, but the current set of problems on iPad and iOS 4.2.1 appear to be a new issue. Frankly, I have noted a number of significant issues with my iPad since upgrading to the new OS that are unrelated to any specific application, and new issues that adversely affect a number of applications. As a fellow iPad user and until we can thoroughly test our next release, I would recommend resetting your iPad (hold the Home and Wake/Sleep buttons simultaneously until you get a screen that says Reset) when you notice odd behavior. I only had to do this once before installing 4.2.1, I find I am now resetting the device every other day to get ‘normal’ behavior back again.