Mysterious "beachball" while typing

I’m a returning user of DEVONthink and one of the things that has always impressed me about the program is its astonishing speed. But something has gone wrong today and I’m trying to get to the bottom of it.

I’ve been frequently encountering the “spinning beachball” when doing low-intensity operations, usually just when typing or adding tags. I’ve tried some basic fixes (shutting down other apps running along side of it, restarting the app, restarting the whole laptop) and the problem seems to persist. I don’t have this issue when typing in other apps.

There’s peculiar activity in the Activity Monitor at these times, too. Generally, DEVONthink’s “Energy Impact” is around a 2 (at rest) or a 4 (when undertaking activity in the app), but during these moments when the app freezes up–just while typing–the Energy Impact skyrockets temporarily to the 800-900 range, even occasionally cracking 1K:

I’ve taken a “sample” from the Activity Monitor if anyone wants a look at it. Will continue to troubleshoot this…

Rebooted the Mac in Safe Mode and encountered the same issue, so it doesn’t seem to be interference from a plugin or anything (those haven’t been changed recently anyway).

Interestingly, when I shut off the wi-fi the problem seems to cease, so it may have something to do with the app syncing? Though I’m baffled as to why it is presenting me with this problem today rather than, say, yesterday (hooked into the same wi-fi system with no changes). [Update: I’ve now seen the problem even with the wi-fi switched off.]

Someone in this thread seems to suggest that they see a beachball when their internet connection is unstable. But my internet connection otherwise seems fine:

Please send the sample to cgrunenberg - at - In addition, is anything shown in Window > Activity? Does this still happen after disabling automatic/scheduled sync?

[updated] For a minute I thought that this was helping, but it appears that issue does still occur with disabled automatic sync. One other clue in this mystery might be that Devonthink To Go is still processing a very large operation I did yesterday, and the mobile app is still showing a “downloading items” progress wheel. Could this problem be occurring when both the iOS app and the MacOS app try to access the Dropbox sync folder simultaneously?

a very large operation

What very large operation was this?

I accidentally moved a group of 18,000 notes from one database to another, and then moved it back. That didn’t take too long for the MacOS app to efficiently grind through, but that’s my best guess for what the mobile app is chewing on over here:

I’m curious where you got 18,00 notes from. Evernote convert? Heavy Apple Notes user?

I was actually an early DEVONthink user (circa 2004) but I got lured away by something else (DabbleDB, if anyone remembers that). When DabbleDB got disassembled for parts by Twitter in 2011 I jumped to Evernote. Evernote has lost its way in recent years, so I’m coming back to the fold, but bringing nearly 20 years of accumulated data with me. :joy:

1 Like

I’ve resolved this issue! Rookie mistake: I had a few other large databases open all at once; closing them all except the large one I am working in seems to have freed up enough RAM to get everything back to normal. This is something I should have tried earlier; apologies for taking up valuable time!


No worries and no wasted time :slight_smile:

How much RAM is on your machine?

8 GB of RAM.

One of my other databases also contained any indexed items which are located in a Dropbox cloud folder, which Christian suggested may have contributed to slow file coordination.

Just a heads-up, and sadly not really fixable: 8GB RAM is barely enough on a modern Mac. When choosing a Mac, always opt for the maximum amount of RAM you can afford. Disk space is easily extendible via external hard drives; RAM is not simply down.

PS: Select the Help > DEVONthink 3 Help > Documentation > Appendix > Hidden Preferences. Control-click the On link for DisableFileCoordination. Then paste into the address bar in Safari, okaying opening DEVONthink.

Next time! :smiley:

In any case, it looks like the beachball problem has gone away with a slightly more parsimonious arrangement of open databases, and I’ll keep an eye on those hidden preferences. Thanks for easing my onboarding.

You’re welcome :slight_smile: