New Database keeps unmounting on import

Hi there, I have scoured the forums and found a partial resolve but does not help with the hangup and unmounting. I created a new database to archive my old emails from 1996 - 2015; total items are around 80k of emails. Whenever I am performing an import of any size from 2000 >= the database randomly unmounts; resulting in me having to delete the database.lock file then remounting. I have tried moving files in batches of 500 <= 1000 that works… but that is only once. When attempting to try it a second time it locks up and unmounts.

Any suggestions?

  • Are you referring to using an encrypted database?

  • Are you on Catalina?

  • Are you using TimeMachine?

@BLUEFROG Great questions, Yes.

Database Type: Encrypted
Note: I have tried using non-encrypted databases w/ and w/o spotlight indexing; still results in the same behavior.
macOS Version: 10.15.3
TimeMachine Mode: Enabled (but inactive)

Are you doing the import in DEVONthink’s View > Import sidebar, the menus from within, or drag and drop from Mail?

I have tried the following methods on both encrypted and non-encrypted databases: Mailmate Commands > DT > Add..., DT View > Import, and Drag & Drop.

Try this, if you would…

  1. Create an encrypted sparseimage disk image of sufficient size in Disk Utility.
  2. Create a new database in DEVONthink, then close it.
  3. Command-Drag and drop it to the mounted disk.
  4. Double-click it to open it in DEVONthink.
  5. Do the import as you’d normally do and see if the disk gets unmounted.

That worked succesffully with the exception of the following error.

This looks like the alert of a script, do you use any of them (e.g. in smart rules, reminders or as triggered scripts)?

@cgrunenberg I was testing a smart rules “on demand” to move imported emails to the appropriate database, but found it was not functioning as expected (mainly an operator error) error was caused with GPG encrypted emails.