New Google Drive File Stream changed path and broke "index files and folder"?

So, I used to index local Google Drive folder in DT3, so I have my index on my mac but the files are actually on GDrive for easier sync across all my devices, and syncing the DT3 db between 2 macs over a local network.

My way was:

  1. create a db
  2. to create a Group, go to “File --> Index Files and Folders” and select the Google Drive folder for the specific db

When Google changed Drive from “Backup&Sync” to “File Stream”, it also did rename the old drive folder and, even though the absolute path to the new one changed, it created a symlink not to break backward compatibility.

In fact, if now I either go via cmdline to $ cd ~/Google Drive/ or if I right-click on DT3 Group icon "Show in Finder", they both take me to the correct new Google Drive location.

BUT, here is the thing: if I add a new file to that folder, I won’t see it on DT3. However, if I annotate that file, I will see it reflected in the file at the new Google Drive location.

I tried to create a new db now, the same method with a test folder in Google Drive, and tried to add files afterward or annotate them, and everything works, so I don’t think is the sync method the issue.

Any ideas on what’s happening and how I could fix it?

Thank you very much

PS: I’m also starting to doubt that I may have used, back in the days when I first created it, the “File–> Imprt → Files and Folders” option instead of “Index Files & folders” to create the group, which could explain why I don’t see the new files popping up in DT3? IS there a way to check this?

It is a known and documented thing that indexing cloud-synced folders may require the use of File > Update Indexed Items with the indexed parent group selected. Cloud services may not initiate a detectable filesystem event for DEVONthink. Also, DEVONthink has to be cautious not to cause inconsistencies in the local repositories of these services.

Thanks for the answer and apologies if it looked like I didn’t RTFM, I swear I did (cuz I hate that too :slight_smile: ) and found one of your previous answers about indexing GDrive like this (specifically this post), but when I tried on the root folder it didn’t work so I thought it may have been a different problem (also because it always worked automatically, and it worked again automatically on the test right now).

I now re-tried to do that per each folder within the Group and it worked indeed, thanks.
the only problem is that now it duplicated the files that were already there (one with the old “relative” path, and all the others with the new absolute path :frowning: ) other than adding the new ones.

This was a small folder with 10 docs in total, if this is gonna happen to the bigger one… dedup everything manually is going to be a bit of hell (also, I’ll have all my tags attached to the “old” ones)… any ideas?


All indexed files are located by their absolute paths, never relative ones.

If you select the indexed parent group pointing to an old location, you can click the Path dropdown in the Generic Info inspector, choose Select, and select the new location. This should resolve the indexed paths in the new location.

1 Like

Thanks a lot, it worked :pray:

Excellent and you’re welcome :slight_smile: