New iOS builds for iPhone and iPad—sync unreliable

I was very excited about installing the new updates for DTTG. And yes, the sync did work once or twice on both my iPad and iPhone. DTTG even allows you to create an item on the iOS device and sync it back to your Mac.

But one or two syncs is all I got out of both devices. After that, they refused to sync. Even after resetting sync settings, rebooting both the iOS device and the Mac.

I have the latest OS installed on everything—Mac, iPad, iPhone. My network is solid and I do wifi syncs all the time with programs like Things, MacJournal, and Daylite. I sync Things to my iPhone probably 10x/day. And if you’ve ever worked with Daylite, you know how huge and complicated that program is. You have to buy and run a separate program called Daylite Server in order to sync with iOS devices. And yet it works!

I think DEVONtechnologies is just new to the iOS syncing field. Maybe they’ll get it right in a year or so; they’re just late starters.

Companies like OmniGroup (in Seattle) got to work very early (years ago) on this. They’ve had some growing pains, but their sync system(s) (in addition to Daylite’s) are pretty dependable.

DTTG is not that big of a program (even though DT is). I would REALLY like to be able to use DTTG, especially since I’ve paid for it. Sadly, it looks like they won’t get syncing to work well until maybe version 2 or 3.

There are other problems besides that syncing stops working completely after the first or second sync. Fonts display unreliably on the iPad; and if you create an item in a folder on the iPhone, DTTG insists on moving it up one level (out of the folder, up to the parent level). Even if you drag it back on your Mac in DT, syncing again doesn’t carry that change over to the iPhone.

Then there’s the problem of being unable to delete items on your iOS device(s). If you decide to turn off syncing for either Global or Database (or both), you’re then stuck with a bunch of entries on the iOS device that can’t be deleted.

Sigh. I should count my blessings, I guess. DT is a wonderful program, and it even works with Dropbox. I’ll stick with that and let go of my expectation that they’ll be able to get it to work (and sync) on iOS devices. Chalk up $14.95 to unrealistic expectations.

DTTG v1.1 still has some problems, but I have had no difficulty in deleting a database, a group and an item, either by sliding a finger along the name in the left panel or by using the trash icon.

Yes it’s sad but the sync is still not working after the 1.1 update. I have to give up and find another solution.

Darn and I thought you’d solved my problem.

I sync my iPad to two databases and my iPhone to one. The DB that is synced only to the iPad is fine as far as I know, and always has been. The other has been a thorn in my side for months. I generally add files in that DB from the iPad. After a sync, there’s no telling what I’ll find on the MacBook, except that I can usually count on losing some data. The file remains, but is empty. I’ve been coping by exporting the two synced groups to my desktop as a backup solution, so luckily I haven’t yet permanently lost anything.

I upgraded DTTG yesterday and today got the iPhone synced perfectly, and made sure that the data on the laptop was also complete (and made yet another backup). I tried resetting DTTG from Settings, but that didn’t work. I was going to uninstall and reinstall the app tonight and let it sync overnight until I read this comment.

So I deleted the db on the iPad that had all the missing files that wouldn’t sync, then I synced again. The db reappeared, I saw the file names flash by as they were added to the iPad - but the db name os grayed

Sorry, fat fingers on the iPad. I didn’t intend to submit at that point.

Anyway, the db name is grayed out. The stats said the first time that there were 3 records and the size was 0 bytes. I deleted the db and tried again with the same results, except this time the stats say there are 140 phantom records. There are in reality only 126.

So I guess I’m back to uninstalling and reinstalling the app. I sure hope that works!

You can edit your own posts. :slight_smile:

jakkke says that sync is not working.

Even if I uninstall and reinstall to “restore” swipe-to-delete functionality (which some are reporting actually works for them), what is the point?

I need reliable syncing.

Loaded DTTG V1.1 on iPad V1 and iPhone 3GS, and running DTPro 2.0.9 on a MacBook Pro.

iPad syncs OK with DTPro - whoopee.
iPhone does not sync with DTPro, problem with connection - aarrgghhh

Both iPhone and iPad are sitting next to each other, on the same wireless network, trying to connect to the same MacBook Pro running DTPro.

Soon be 6 months that this has been a problem.

I didn’t have sync problems with the earlier versions of DT To Go, and that continues to be the case with DT TG 1.1.

I’ve got my iPad 1 and iPod Touch (2010) synced to databases from my MacBook Air, and my iPad 2 synced to databases from my iMac.

I’ve added content to all three of the mobile DT TG databases, including new groups containing plain text notes, Bookmarks and HTML documents, and synced them back to their Mac counterparts. I’ve done searches (using the much larger index possibilities of version 1.1), added labels, and deleted individual documents or entire databases from the mobile devices.

Note that if new content on the mobile device is added to the Global Inbox on the mobile device and then synced back to the Mac, DT Pro/Office users will find the new content in their Global Inbox. But if a new note is added to a new group or to an existing group in a database, the new content will be found in the Mobile Sync group on the Mac.

Sync variables: Many academic and corporate networks deliberately block communications between a Mac and another device, for security reasons. Also, home network variables and firewall settings (as well as signal strength issues) can sometimes cause sync problems.

For those reasons, I make it a practice to create a new local network on the Mac that hosts my databases, then set the mobile device to use that local WiFi network. To create such a local network, click on the Network (WiFi) symbol in the Mac’s menubar and choose Create Network. A new local WiFi network is created – it’s just that simple. Your Man’s WiFi radio doesn’t produce a wide-area signal, so it’s best to place the mobile device near it during sync. After sync, switch your Mac (and iOS device) back to its normal network.

Although my iOS devices hold 64 GB and could load several of my large databases, I usually replicate into Mobile Sync only those items I want to use on the mobile device, such as a project group that holds my references and notes, a set of trip-related items, or whatever.

Several days ago I synced some bibliographic citation notes (items not readily available on the Internet) to my iPad and visited a library. I was able to examine some of the references for utility for a project and enter notes about the more useful ones. As an added tool, I took my pocket-sized LX3 digital camera (with an f2.0 Leica Summicron lens and big sensor chip) along to photograph a few pages and later OCRed the images into my Mac database. The iPad, DT To Go and my little camera made that research adventure much more pleasant than when, in the old days, I had to rely on scribbled notes on index cards, which later had to be typed (my handwriting can get hard to interpret, later).

“Sync variables: Many academic and corporate networks deliberately block communications between a Mac and another device, for security reasons. Also, home network variables and firewall settings (as well as signal strength issues) can sometimes cause sync problems.”

Same network, same Mac laptop, same database. No signal strength issues. In other words none of the variables you mention. Works on iPad, doesn’t work on iPhone. I’m glad it works for you, I really am, but it doesn’t work for me.

“Sync variables: Many academic and corporate networks deliberately block communications between a Mac and another device, for security reasons. Also, home network variables and firewall settings (as well as signal strength issues) can sometimes cause sync problems.”

That is not the case with a lot of us here. We know what we’re doing. I’ve been in IT 30 years.

My home network is rock-solid. Recently-purchased Airport Extreme, multiple Macs, all with latest OS X, multiple iOS devices, latest iOS.

If Daylite can sync over a wi-fi network, anything (reasonably) should be able to sync.

I’m not saving DEVON is big, bad, evil, or dumb. Apple itself is in a major pickle right now with MacBook Air users who can’t run iTunes because it freezes the whole machine!

But I do think DEVON needs a whole new iOS dev team. They build a great Mac app, but these sync growing pains are reminiscent of problems MacJournal went through when they added iOS sync.

OmniGroup and Things (Cultured Code) are very stable sync platforms because they’ve been doing this for years and have a good iOS dept. That’s what DEVON needs.

It’s all relative, or situational as the case may be. I’ve probably tested 100+ beta releases of DEVONthink To Go over the last 18 months and beginning with the release version of DTTG, syncing has been rock-solid and reliable for me. I’ve not encountered any of the issues that others are reporting here. I’m not suggesting that there are not problems, but the beta testers are apparently not encountering them. At some point, the other variables in the configuration of the systems may come into play.

On the other hand, syncing with Cultured Code’s Things has been nothing but problematic for me, and many, many others, for some time now. Here is a link to just the latest issue to come up when syncing. I also still see the ordering of tasks in Today jumbled when syncing, even though the latest releases were supposed to address this problem. I’m allowing for the possibility that there could be something with my configuration that is causing this that the beta testers did not encounter.

I have just started using DT on the mac and so far love it. I also bought the DTTG for the ipad and iphone. The first time I synched, all went well. But since then I have not been able to synch on either of the IOS devices. On my ipad I either get a connection error, or if I restart the Mac DT app, I will get a one second synch, which wiped out all of the previous data on my ipad DT.
On the iphone can not get connection or if I do, the synch hangs one third of the way.Setting up a separate wifi network, did not help. I have OmniFocus and Mac Journal and they both synch seamlessly on the ipad and the iphone.
I must say that I am beginning to regret my purchase of DT altogether.
Once you see problems like these and the authors denying them, you sort of lose trust in the whole app and as I am transferring a lot of information into DT, scanning papers to go paperless etc, I can’t afford to find out that I might loose all my data. I really am not sure where to go from here.
Any advice from long time users would be appreciated.

There are no long time users of DTTG, as it’s a new product.

I’m a long time user of DTP – it’s one of the reasons I switched to the mac – and have found it to be rock solid reliable. So much so that I’ve had only minimal need for support, but the support team has been competent and responsive.

I don’t think anyone is “denying” the sync problems with DTTG, but it is much more difficult to fix a problem that the developers can’t reproduce.


Thank you Katherine for your reply, it is reassuring to hear that DT on the mac is rock solid and that I presume you have not lost any data on it.
I did not mean to suggest that the developers are shirking responsibility for fixing the problem, but my point is that since we are using apple products, one manufacturer , one OS, it should be possible to reproduce these errors. My system is quite basic, I have a new 4 month old iMac, new six month old iPad and a 1 month old iPhone. they are all running the latest software, I could understand a problem like this on the PC side from where I came 4 mnts ago, where the computer could be something I built myself, the tablet from some manufacturer and teh phone Android or windows or iphone, but here all is uniform, so what is the hang up?

While we may all be using Apple products, we are all using different networks to connect them.

I personally have had no problems syncing since the latest update. (Before, I only had a minor problem with being unable to delete some content created in DTTG.) Of course, that’s not helpful to people who are having problems, so I haven’t posted before.


Im using airport extreme for my home wifi network , if that makes a difference?

Tough to know what makes a difference and matters.

Anyone remember if Dtech has posted which specific information they’d like to collect from people that might help isolate causes of different sync-related problems more efficiently? Seems to me it would be worthwhile to create a template that focuses/improves the data reporting/gathering process.

makes sense to me, i am ready to provide any details that may help.

I’m having a synch problem. I hadn’t synched for over a week I guess. Added some files on the mac. Then today I decided to move a large folder into its own database on the mac. The mac databases verify.

But on the itouch it won’t synch. The new database shows up in name only, but empty. The attempt to synch only lasts a second or less, then the itouch goes back to the screen showing the databases. I guess I’ll wipe and reinstall the app on the itouch.