New items in DTPO on Mac not syncing over to DTTG

The other way around, from iOS to the Mac, it works.

I reset my synchronization settings to no avail.

Any ideas?

Having to hold my breath every time I sync my devices—always lacking the confidence that the sync has been completed with consistency—is becoming very tiresome. I would kindly ask DevonTechnologies to make an exception to its non-disclosure policy and let us know when DTTG 2 is estimated to be delivered. Some of us (most of us?) use this product professionally and, unlike the desktop product, which is terrific, DTTG clearly does not deliver at that level. I think it is only fair to us, longstanding customers, that we know the approximate timeline, so that we can adjust our workflows in case it is prohibitively long. Summer is the best time for such housekeeping, should it prove necessary. Thank you.

UPDATE: I closed DTPO and deleted the Sync folder in the DevonThink Application Support, in addition to all DTPO cache files.

Then I uninstalled DTTG from my iPad and reinstalled it. Set up syncing and synced from scratch.

Surprisingly, the problem persists: a couple of files (at least—how can I know the exact number) that reside on the desktop do not get synced over to iOS.

My database passes the verification test on the desktop (no orphans, no other apparent issues).

I have a flight to catch in five hours and will miss those files.

There are a lot of good iOS document tools available today-Documents and PDF Expert by Readdle and Notebooks by Alfons Schmid are two that I use extensively. I suspect that many people still use GoodReader on iOS. Notebooks is especially useful if you are creating Formatted Note HTML documents in DEVONthink (that is the rich text document format in Notebooks). Your documents can be stored on Dropbox and indexed into your DEVONthink database(s). Sure beats trying to push a rope…

Thanks, Greg, I do use PDF Expert for the bulk of my reading (which I do on the iPad anyway), and I prefer it to GoodReader, which is richer in features but very cluttered. I was oblivious to Notebooks but will take a look—for now I use as most of my writing is in plain text.

As I wrote yesterday in another thread, my strategy is to gradually minimize the amount of information I store in the proprietary DT database, and index most of my content. I guess I should try to complete this process sooner and become as independent from DTTG as possible.

There is stuff, however, which I must keep entirely within the DevonThink database, and for those items, the unreliable syncing is both counterproductive and, frankly, anxiety-inducing.

I hope the DevonThinkers will oblige us with some concrete information about the projected timing of events.

If you must use DEVONthink to Go for some documents, there is one thing you might want to try. I found that syncing was most reliable when I avoided syncing documents in the Global Inbox of either app. That did not completely fix the sync issues, but it appeared to help with my situation. Eventually I decided that continuing to do something while expecting different results is insane.

Interesting observation, Greg, but in my case the offending files are in subfolders of the database, with no content whatsoever in any of the Global Inboxes.

I sympathize, it is insanity indeed.

I must dash, but as a final note: I understand the DevonThinkers’s resistance to announcing release dates that the vagaries of software development may render impossible to meet. At first I was even appreciative of this cautious stance. But the line between responsible reticence and disorienting obscurity can become very thin. If anything, such uncertainty is not a courtesy to customers, even if it makes business sense in some other apparently overriding way.

It’s not advisable to rip things out of the Library. In this case, that folder has nothing to do with DTTG synchronization. (Easy to verify – watch that folder while you synchronize with DTTG – nothing happens inside that folder.)

Anyway, did you verify that the things you want to sync are actually replicated to your database(s) Sync group? That they are not locked? That they are not “missing” (i.e., mis-indexed files)? Or any other other faux pas that prevent syncing? (I’m not trying to be disrespectful, but over here it is usually when I’m under pressure to get out of the office that I fat finger things that are obvious in calmer times.)

In a pinch, mail them to yourself then from iOS Mail “Open In” DTTG.

… anyway, I’m with Greg. There are far better workflows available with the tools Greg mentions (and others).

Oops. Luckily the database verification test succeeds. Do you happen to know whether I wiped out any database contents as a result of my butchering the Library/Sync folder?

Not disrespectful at all, thanks for trying to help. None of these oversights in this case, but what DID work was deleting DTTG once again and restarting the iPad. Go figure…

And I’m with both of you. I will move as much stuff out of the database as possible so it can “breathe” better, index it, make it more easily available to the multitude of task-specific iOS apps. Sounds like a smart thing to do anyway, especially in light of the upcoming iOS8 developments (apps sharing files and the like).

(Meanwhile: Flight delayed—maybe yet another bug?)

It seems that you have already solved your problem. Nevertheless, it might be helpful to report on my recent sync issue between DTPO and DTTG. After a year or so of absolutely perfect syncing between the two (and I have almost all my databases synced, several GB, because I cannot deal with the issue of having to come up with files to sync on short notice just to find that I missed something), I suddenly had massive issues a few weeks ago. Many files would not sync, some would. No clear pattern. I reset DTTG, no help. I reinstalled DTTG, no good. I reinstalled DTPO, nothing. I verified, repaired, rebuilt DBs. Still nothing. I was about to give up.
The one clue was that I had just undertaken a fairly massive reorganization of my files in DTPO. I shut down all DBs, so I only had the Global Inbox with 20 entries running. Sync would only transfer 18.
At some point, I happened to note that due to the reorganization I had a lot of files in the trash. Since I had no other ideas, I deleted the trash. Bingo, after that all 20 files synced. Brought back my other DBs. Would still not sync properly. Then deleted their trashes, and again, smooth sailing.

Upshot: The sync process does not seem to like large trash piles. I’m not clear what “large” exactly means. I had many items in the trash before and things were OK.