New Pinboard import and update script

Yes I do, about 180 of them

OK. And the Token you copied into the script looks something like this:

<your Pinboard username>:<lots of numbers and characters>

If it does not, please have a look at and copy the “API Token” that‘s displayed there into the script.

First off, thanks for your help. I double checked the details and everything was good. Just got home and decided to delete the script and start again and everything works :smile:
Have no idea if I accidentally deleted something from the script without noticing or something like that but it’s working now. Again thanks for your help, it’s awesome having Pinboard in Devonthink

Any special permissions that need to be granted for the script to be executable from Scripts menu within DT3? After modifying the code to point to the destination database and to use my API key, I select “Pinboard.scpt” from Scripts > Custom (where I saved the file) and nothing happens–nothing in log, no movement in Activity window. Strangely, when I open in Script Editor and press :play_or_pause_button:, the script seems to execute but is painfully slow (i.e., one bookmark every 3-4 minutes). Am I doing something wrong here?

I haven‘t made the jump to DT3 yet. So I am a bit blind sighted there.

Does anything show in the log? In DT2, you open that via the Window menu, entry is called either Log or Protocol.

If there’s nothing there, I am afraid I don‘t know what‘s wrong.

As for the speed, one bookmark in three minutes is way to slow. But first things first. Is there anything in the log?


Thanks for your reply–the only way that anything appears in the log is if I execute the script by pressing :play_or_pause_button: within Script Editor; trying to execute by selecting the script from the scripts menu within DT3 produces absolutely nothing in the log and no action that I can detect.

Is there a way to run it again without duplicating earlier imports?


Made the jump yesterday. My scheduled run at 10pm survived, script ran successfully.

Can you provide me with your exact copy of the script, redacted to NOT include your Pinboard credentials?

It would never import a link it already imported. See line 129.

1 Like

I ran the importer and got “Import has finished.”
The script created a Pinboard group but it is empty.
I tried again, this time deliberately providing invalid Pinboard credentials - same message and result.
The invalid credentials were not detected.
I manually opened the Pinboard url from the script, in a browser window, and was prompted for my credentials, and on entering them I received the XML result.

Hi @IndigoHomme. Sorry for my late reply!

I am not sure what is going on there. Are there any error messages in the Log? Go to DT‘s Window menu and select Log to display it.

How many links are in your Pinboard?

Updated to Big Sur yesterday. So I am on DTP 3.5.2 and macOS 11.1. The script runs fine.

The current version is 3.6.1. Please stay current with our updates, especially since you’ve moved to Big Sur.

As of yesterday, the update menu would not show me 3.6.1. Now it does. Must have read your post.

Hi there,

I’ve just started using DTP3, and love the idea of being able to search my 20k+ Pinboard bookmarks.

When I install the script, and add both database location and Pinboard API, I get this error result:

‘error “DEVONthink 3 got an error: Invalid argument info” number -50’

I’m a script newbie, so probably something v basic?


It might help if you quoted the parts of the script that you changed. Please enclode the code in three backslashes like so
code goes here

Thanks Chrillek,

Only code I changed was:
‘’’ ‘property dtDatabase : “/Users/emrys/Databases/Research.dtBase2”
– We use your Pinboard Auth Token. See
property pAuthToken : “semrys:6b94bb007eca3d1ed1b4” ‘’’

Try running the script in script editor. That’ll at least provide an indication where the problem arises.

I tried it in the script editor, and the result is as in the screenshot:

Please enable error messages and traceback by clicking on the little list-like icon at the bottom-left in Script Editor
Bildschirmfoto 2021-02-10 um 14.18.47