New (?) & problematic behavior of "esc" key in split-screen mode


Let me preface with saying that when making note from documents I’m preparing I’m almost always using split-screen mode with the document on one side, and Devonthink note on the other. Therefore the very annoying change in behavior must be relatively recent as I haven’t noticed it last time I was doing this.

The problem:

When two windows are open in split-screen pressing the escape key moves the active window back to the main screen (desktop). This is normal behavior.

However, when using Japanese front-end-processor, the escape key serves also to undo all the automatic character conversions and return to the blank state with the text the user has entered. This is a very important function when taking notes including new vocabulary, characters you rarely use etc. (as the front-end-processor gets its suggestions wrong in such cases and the user needs to go manually over some words in the sentence). The regular behavior of Mac OS applications in the case Japanese f.e.p. is used in the split-window mode is to give priority to the f.e.p. and move the window to the main screen only once the f.e.p. is done with reverting all the automatic conversions (which may take several presses of the key, the last press removing all the entered text altogether).

Yesterday I’ve noticed it’s no longer the case in Devonthink. The window reverts to the desktop as soon as I press esc, and the f.e.p. starts reverting its suggestions from the second press on.

This is rather annoying and makes split-screen mode practically unusable. Would it be possible to change the key-press handling priority back so that the normal Mac OS behavior is restored?

Thanks in advance.

Are you sure it’s related to an update of DEVONthink and not to one of macOS? A screenshot of the window before/after pressing Escape would be useful of course.

I will do more tests by the end of the week (quite swamped right now) and try to make a video clip to illustrate the behavior.


  1. I’m sure the problem was not there two weeks ago when I was writing some japanese notes and would notice the problem. (on the other hand I might have used different arrangement than split-screen, so I’m suddenly not so sure…)

  2. Other applications (tested with notes and firefox) don’t show this behavior (i.e. they properly cancel the conversions first and only then the split-screen). In fact Firefox doesn’t return to the desktop on the esc press at all.

  3. There are some other shortcuts that do not work properly (ctrl+1 or ctrl+2) but I guess that’s because Devonthink uses them for something else. I wonder if FEP shortcuts shouldn’t take precedence, but these 2 are active when Japanese text is selected, rather than during text input, so I’m not sure if this can be helped.

What is this?

A piece of system software necessary to type in Japanese and some other Asian languages. Essentially you type in latin text transcription and the system converts it to hiragana (syllable based writing system) on the fly… and as you complete the sentence it also automatically analyses the meaning and choses right kanji (Chinese characters) for the words the user has typed in. Front-end-processor is the software that handless the process.

Except that it gets the suggested conversions wrong from time to time and you have to edit it and choose characters by hand… the first step to undo the default automatic conversion is to press “esc”. Hence the problem.

Interesting. Is this a publicly available application or part of a larger system?

It is part of every operating system, including iOS and Android. Obviously Google, Microsoft and Apple have their own solutions. Apple’s used to be called “kotoeri”, but for some reason they don’t mention the name anymore. There also exist third party solutions such as ATOK.

Even if you use Mac OS in english, if you turn on Japanese text input, you’ll enable the built-in front-end-processor. You may notice how the usually brief input menu gets multiple additional functions, or how typing starts working differently than in Western languages, when Japanese input is selected.

1 Like

Gotcha. Thanks for the clarification. :slight_smile:

Sorry for the delay - got so busy I forgot I was to follow up with the screen grabs… but I experienced it again today and it all came back.

Below are two examples of typing notes in split screen - the first shows proper behavior in Apple’s notes. First I type the whole sentence “This is an example of correct behavior” in Japanese, and press ESC to undo the conversions. After that I press ESC again to undo the entire sentence. Then I write it again, confirm first part of the sentence, type the remaining part and now pressing ESC affects only the end of the sentence. At no point the window closes - even pressing ESC after undoing the entire sentence does not close the split-screen setup.

In the second example I attempt to do the same thing with DevonThink (a markdown text note), but as soon as I press ESC the split-screen is closed and only after that the ESC returns to its proper behavior (undoes the typing).

(sending links to youtube as I couldn’t upload clips here directly)

  1. Screen capture 1
  2. Screen capture 2

Which version of macOS, which keyboard layout and which system language? Does it work in TextEdit?

Mac OS Ventura 13.4.1(22F82)

I use Logitech MX keyboard with US layout I believe.

On the system side I have Japanese - Romaji input selected. The active sub-modes are Hiragana, Katakana, Eiji, Zenkaku-Eiji. Japanese input mode automatically adjusts to either JIS or US layout, so there should be no problem with keyboard being non-japanese.

System language is set to Japanese.

Text Edit works exactly the same as Apple Notes on the clips I’ve linked - that is it does not quit split-screen mode on ESC press and allows me to undo the conversions properly.