No feedback by hopping icon

Hi there,


I have some troubles with the feedback I want to gtby the Devonthink Icon in the Dock.

When I highlight text on a website and save it in my database through the services shortcut everything is fine: The icon hops in the dock and a red star with “1” shows, that there is a new item in my database. And in the inbox it is also shown that tehre is a niw item (1/23).

But: When I use the bookmarklet for Safari (I use 4 beta) to pull a pdf of the website to my database, the behaviour is totally different. The pdf is in my inbox, but neither the icon hops nor the star is showing nor the inbox shows, that it has new content.

A bug?

Meanwhile I tried the HTML-bookmarklet: No hopping of the icon, but a red star with number. And in the inbox it is also shon, that there is a new item.

Which bookmarklet did you use and what’s the URL? However, the web page has to be loaded & rendered again to create the PDF, this might last a while.

e.g. I use this forumsite (with Safari 4 beta, but if I remember right, this also was a problem with the older Safari).


I use the PDF-Bookmarklet (not paginated).
The Icon does not hop, but it shows a red star with a “1”.
The inbox shows 1 new item (1/23).

I use the HTML-Bookmarklet
no hopping icon, no red star, no “1”

The inbox shows 1 new item (1/24).

By the way, after clicking a bookmarklet, the Safari´s bookmarkbar, and all the rest greys out, to show that it´s processing, but it never comes back in the old color… I waited, but nothing happens.

Not with pdf-bookmarklet, not with HTML-bookmarklet

It should immediately return as the bookmarklets don’t perform any real actions. Reinstalling DEVONthink and/or ensuring that there’s no other instance of DEVONthink and/or some system maintenance might fix this.

In addition, which destination is selected (see Preferences > Import > Destination)?

destinations is the Inbox of the active database (I have just one database at the moment).

I will reinstall DTPO and let you know.

I reinstalled DTPO, reinstalled the Extras folder, reinstalled the pdf and html-bookmarklet – but still the same.


no hopping icon, no red star
but in the database it´s shown that there is a new item.

no hopping icon,
there is a red star with “1”

in the database it´s shown there is a new item.

And in both cases, Safari stays in the pale grey color it does not turn back to the grey of an active window.

Any Safari add-ons on your machine? Did you try perform any system maintenance, e.g. rebuild the LaunchServices? Do the identical scripts for DEVONthink Pro work as expected?