No window opens upon launch


I have searched the forums for help, and perhaps I just missed something. Here’s my problem. When I launch DTPro (1.5), I get no database. The program launches, the menubar activates, but then… nothing. Up until this afternoon, my “Work.dtbase” file would open, and that was that. But now, it doesn’t. I have no idea why. There’s also no splash screen telling me that the database is being loaded.

I suspect that the database has been corrupted somehow, but couldn’t begin to guess how. Still, if anyone can help, I’d appreciate it.

With DT Pro open, see if your database will open, either from File > Open Recent … or by double-clicking the database file in the Finder.

If your database opens, choose File > Database Properties. Is the option to make this your default database checked? If not, check it. One of your databases should be designated as default.

If your database simply won’t open, send us a message at Support and we will work you through a procedure to recover a working database.

In neither of these situations does it actually open. Therefore, I can’t check on the properties nor rebuild the database.

I have tried making a new database, as well. I do have that option in the menu (it’s one of the few menu items not greyed out). This new database will also not open, even when made the default.

Will do! I really appreciate your help. I’ve always been impressed at how well you guys respond to these forum posts. Thanks.

I am having this same issue…

Got it to finally open again by deleteing DT’s preference .plist file from the ~/Library/Preferences folder…

This is now the second time its happened and each time I have to manually go through DT’s preferences and reconfigure everything…

Why does this happen and how can I make sure that it doesn’t happen again?

I checked the to see if I could find the problem that might be causing DT to not open the databases upon launch, and I think I may have found some relevant info, but can’t make any sense out of it myself…perhaps someone else might be able to, and might be able to let me know what the issue is…Here is the relevant info from the

FYI: I do have a Fujitsu Scansnap scanner that I use with DT, but not an ExactScan (which is referenced multiple times in the console text I previously included…

The ExactScan lines are OK. No problem.

DT Pro will open without a database unless a default database has been specified in Preferences or in Database Properties.

But DT Pro can also open a database without an open window. So check by pressing File > New Window if you think a database hasn’t opened.

If you have both set a default database and checked the Preferences option to open the windows that were last open at quit, all should be well.

Choosing File>Open New Window worked!

I didn’t realize that not having the ‘open the windows that were last open at quit’ preference setting enabled would mean that the database would open, but no show ANY windows…I figured this meant that it would of course always show the main/root window, but if I had tons of groups open in their own windows, then those wouldn’t be opened…

Not really sure why there is even an option to have DT open a database with none of the windows open, but nonetheless, thanks for the tip in getting things working properly!

If you haven’t set a default database and launch DT Pro from the Finder, it will launch without an open database. That’s especially undesirable if you have triggered another application or script to try to send data to DT Pro; there’s not an open database to receive information.

The preference to open the set of windows that were last open at quit is linked to (requires) that one of your databases be set as default, to do what you expect – to open a database and display windows whenever the application is launched.

But of course, if you have set those preferences but close all the open windows before quit, the next time that database is opened it won’t have an open window. And there are other options for displaying windows at database opening, including None. That’s freedom of choice. :slight_smile: