OCR and Indexed pdf files

When I OCR indexed pdf files to searchable pdf files Devonthink creates a copy with the filename extension -1 after original filename. This copy is only visible in the original indexed folder. Is there a way of having devonthink replace/overwrite the pdf instead of making a copy? I have tried to check “Move to trash” after conversion in the OCR preferences, but this seems not to work with indexed files.

How do you actually perform OCR? On demand via Data > OCR or automatically via smart rules or after scanning?

On via Data > OCR

That is the anticipated behavior when doing OCR on an indexed file.

If you use a smart rule with an OCR > Apply action, you should be able to avoid that behavior as the action doesn’t produce a new file. It processes the current file in place.

@cgrunenberg: I’m not sure if there’s a technological stumbling block but would it be possible to make the Apply command an option in the Data > OCR menu as well?