OCR plug-in won't install


I am running DTPO PB2rt2. When I first installed the program I clicked on the install OCR plugin, and it installed without a problem. I used it and it worked fine. Today I went to OCR a pdf, but nothing happened. I looked under help/install plug-ins, and OCR was not checked. I checked it and hit install. My computer downloaded the Abby plug-in and everything seemed to go fine, but OCR still does not work, and when I check the help/install plug-ins menu, I see that OCR is still not checked. I have now done this twice with the same result. I have also reinstalled DTPO from scratch. Still no dice.

I am new to macs, so I’m sure there is something I am missing, but I can’t figure it out.

Thanks so much for your help.


If the ABBYY OCR software has already been installed, then when one selects Help > install Add-ons, the checkbox for ABBYY will NOT be checked, as there’s no point in downloading it again.

On the first attempt to run OCR, there may be a pause while OS X examines the Scribbler application. In fact, the first attempt at OCR may fail for this reason.

Try again. From this point forwards, OCR should work every time.

Thanks for your reply Bill,

But it does not work on the second, third, fourth try …

I have the context menu item “convert to searchable pdf,” but it does not seem to do anything. When I call up the OCR activity window it shows no activity either.

Don’t know what else to tell you.

thanks for your help.


Please open the Console application in Applications and Utilities and copy all the messages that contain “DEVON” and email this to support@devon-technologies.com. Then we can take a look at it. Thanks!

Done. Thanks for looking at it.


So far no one has been able to figure this out, so I am sending this back out to the whole forum to see if anyone has any ideas about what is wrong with my machine. I am working on an almost new macbook.

When I first down loaded the latest beta update, everything worked perfectly. Now, convert to searchable pdf produces no activity in DT at all. When I invoke that operation, nothing shows in the log, or in the OCR activity window.

I now see that my import from scanner, both from exactscan and image capture, does not work either. It looks like it is going to import the scan, but freezes or simply fails to import without accomplishing the task. Both exactscan and image capture work fine when I use them outside of DTPO.

So, this is where I am. I have deleated DTPO from applications and its library location, downloaded a fresh copy, and reinstalled, but I get the same behavior.

I am new to the mac (DTPO was one of the reasons I switched,) so I certainly might have done something to mess things up without knowing it. Right now I am at a loss. Any ideas about how to troubleshoot this would be greatly appreciated.



Matt, you can check to see if the ABBYY OCR software was actually installed. It should be found at ~/Library/Application Support/DEVONtthink Pro 2/ABBYY/.

If that folder isn’t present at that location, or is empty, perhaps your computer has a Sharing & Permissions error, which can be corrected this way:

  1. In the Finder, select the folder named Application Support at the above location in your User Library.

  2. Press Command-I to open that folder’s Info panel. Inspect Sharing & Permissions, near the bottom of the Info panel. You (as the User) should have read & write permissions for that folder.

2a) If you do not have read & write permission, click on the Lock symbol and enter your administrator password to unlock it so that permissions can be edited.

2b) If you are not listed as a User, click on the “+” symbol and choose your User account from the list that’s displayed. Else, move to the next step.

2c) If you do not have read & write permissions, change to give yourself read & write permissions. Else, move to step 3.

2d) If you had to make a change in either or both step 2a or 2b, click on the Action button (Cogwheel symbol) and select and confirm the option to set the changed permissions to items enclosed in this folder. Then close the Info panel. Now go back to DTPO2 and choose Help > Install Add-ons. Check the ABBYY box and confirm, so as to download and install the OCR software. Now you should be able to OCR scanner output and to convert image-only PDFs to searchable PDFs. END.

  1. Move to the next folder down within the Application Support folder (the next will be DEVONthink Pro 2, after that, ABBYY). Select that folder. Go to step 2, above.

Thanks for your help.

What finally cured the problem was erasing all the preference files and doing a totally fresh install of the program. Everything seems to work fine now. Sorry for all the trouble.

best wishes,