OCR to searchable PDF does not work

Hello All

When I try to convert a file to a searchable PDF, the process never gets completes.

The activity window only says: adding document
but it never finishes.

I´m using DevonThink 3.8

  • Does this persist after quitting and relaunching DEVONthink?
  • If you check DEVONthink 3 > Install Add-Ons, is there an OCR update available?

Yes, it persists after quoting DEVONthink

There is no OCR update available in the Install add-ons screen.
Something odd I noticed is that the PDF services don’t seem to install after clicking on the install button.

Is this a file you are importing, or a file which is already in your database? If the former, does DEVONthink have Full Disk Access?

It is a file I imported into the database.
How do I verify if DEVONthink has full disk access?

I verified DEVONthink has full disk access.
The problem persists

Have you restarted your Mac?

Did OCR previously work? If so, is it obvious to you when it stopped working (eg when you updated to 3.8 or whatever)? Does the problem occur regardless of which document you try to OCR?

Yes, I have restarted my Mac and the problem persists.

I bought and Installed DEVONthink this morning :slight_smile: , so OCR has never worked. This is the first file I try to convert.

Ok, so bearing in mind that Jim is already involved and actually knows what he is doing, whilst I am restricted to guessing, what I would do would be to:

  • close DEVONthink
  • go to /Users/yourusername/Library/Application Support/DEVONthink 3
  • delete the Abbyy folder
  • reopen DEVONthink
  • select DEVONthink/Install Add-Ons from the menu
  • select ABBYY FineReader OCR and click Install

Note that the download is approx 600 mb and may take a while.

PS it is normal for PDF Services not to show it has been installed - DT has no feedback from the OS with that regard.

In my experience there will be no harm done from following my steps; however, I am just a regular here - Jim (@BLUEFROG) is from tech support and might well suggest another path if you are inclined to wait for him to come back online (I’m not versed in US time zones, so I’m not sure when that will be; he does generally look in on Sundays, though).

Hey, and I assume you have purchased the Pro edition? You can check at About DEVONthink 3 in the menu; the window which opens will show “Registered Pro edition to” if you are using the Pro version.

When you asked if DEVONthink had full disk access, I checked, and it did not, so I gave it full disk access. Unfortunately, as I previously said, after giving it full disk access, the problems persisted.

But it means that when I installed the OCR add-on DEVONthink did not have proper access, and it failed?

This is what I found inside the abbyy folder in the path you specified

No, I don’t think the installation failed for that reason; but I think I remember having seen a similar problem in the forum a good while back, and I think the conclusion was that the download probably didn’t properly conclude, leaving a defective copy of the OCRHelper.

Have you restarted DEVONthink since doing that?

after deleting the folder and re installing the OCR add-on, the problem persists.

I’ve just searched the forum and here Jim suggests to the user of an m1 Mac that granting FDA to the OCRHelper app may help. I’ve just checked, and on my Intel mac, the OCRHelper app does not have - or need - FDA. And the user sadly didn’t provide information on whether it was that step which solved the problem or not. Worth a try though (but do remove FDA from the OCRHelper app if it doesn’t help).

Presumably you have tried more than one PDF and none works? Is anything logged to the log (Window/Log)?

If this step also does not help, I would suggest waiting the day to see whether Jim provides the solution here, and otherwise opening a support ticket.

I gave the OCRHelper app full-disk-access, and the problem persists :confused:

Yes, I have tried different files. I need to convert various screenshots into OCR PDF files (I do this all the time in DEVONthink to Go).

I am indeed using an M1 mac (MacBook air).

Have you rebooted the Mac?

PS: sorry for the tardy reply. I have the flu. I’ll spare you the details :grimacing:

Do you mean restart or shut down the mac?
Yes I have

Where did the PDF originate?

From Devonthink.
I have several screenshots that contain text. They are PNG files. I imported the PNG files into a DEVONthink library.
I tried to convert the PNG files into OCR Pdfs directly, and I had this issue. Then I converted the PNG into a regular PDF, that worked.

Then I tried to covert that pdf into an OCR pdf, that did not work

To help track down where the OCR is failing, could you turn on OCR logging, to do this:

  • Quit DEVONthink
  • In Finder select the menu Go->Go to Folder, copy and paste the line below and press Go.
    ~/Library/Application Support/DEVONthink 3/Abbyy
  • Copy the file OCR.plist (274 Bytes) to this folder.
  • Restart DEVONthink, if the OCR fails could you send a copy of the log files. The easiest way to do this is in DEVONthink select the Help menu and whilst pressing the Option key select the “Report a Bug” menu item. This will open an email with the logs attached. If you make it for attention of Alan.


I have sent the log files by email using the Help Menu