OCR without changing file name

I have a database with indexed only files and no imported files. Most of the files are OCRed but some are not. I created a Smart Group with file is PDF and word count is zero.

I want to go through and OCR and overwrite or delete the original, and keep the same file name. In the OCR preferences I have “Move to Trash” selected.

What I’m finding is that instead of overwriting the original file, it’s creating a new file and adding -1 to the name to the file in the finder. So all of the files now have a new name with -1 at the end.

Is there a way to do it differently? I know in Acrobat I can overwrite files when OCRing.

Development will have to asess this.

If I just use Acrobat to OCR and overwrite the file and keep the name, is there any issue with DT in an indexed DB?

In indexed folder: choose files you want - “Move into database” - OCR.
You will find your files indexed in this folder with the original names.

is there any issue with DT in an indexed DB?

We don’t run Acrobat here but I wouldn’t suspect an issue.

I have the same issue as @Turtleboy. I use Bookends for my scientific references and have indexed the Bookends folder into DT (and everything else imported). I have so far used Adobe Acrobat to ocr the pdfs there, but now I am trying to use a smart rule in DT to ocr the pdfs automatically if needed. However, it does not work as DT is not overwriting the original file, which I do manually in Adobe Acrobat, but creates a new file that Bookends doesn’t link to its record. In short, is there a way to ocr an indexed pdf and overwrite the original?

Set up a smart rule like so…

Then drag and drop PDFs on it as needed.

That works like a charm as long as I drag and drop one at the time. Thanks! However, if I try to drop a bit more files in one batch, I get error messages in the log and nothing happens after the files have been processed (it looks like it is working, but no results). The same happens if I am trying to automate the process by changing the setting under “Perform the following actions:” in the smart rule. What am I doing wrong? It is the same smart rule doing the work.

And what would these messages say?

I just wiped the log, but basically that OCR failed