Odd behaviour with links to PDFs in RTF docs

I’ve just started to notice some very odd behaviour with embedded DTP links to PDF documents. (e.g. a link is created in an RTF document to a PDF). This has always worked properly in the past, with clicking on the link opening up the PDF.

Now with v2.5.3, clicking on the link tries to open the pdf as though it was a sub-window within the RTF document, with the PDF masking part of the RTF. The sub-window can’t be moved, but the PDF can be paged through.

It’s a very strange effect – please see the screenshot below.

BTW it only does this if I click on the link – if I use the context menu to Open Link it still behaves correctly.

These are not new links and they’ve always worked in the past.

Anybody any idea what’s going on?



Posted in case anybody else ever gets this issue.

Support were unable to reproduce the issue – the test file I sent them didn’t exhibit the same problem on their machine as I was experiencing on mine.

In the end, I was able to make the problem go away only by deleting the main preference file (~/Library/Preferences/com.devon-technologies.thinkpro2.plist) and allowing a new one to be created automatically.

There’s clearly something in the old preferences file that is causing this behaviour – I’ve sent a copy to support to see if they can find out what that is and whether there’s any fix needed.

In the meantime, if you do see this problem, then the cure is to delete your preferences file.