One computer doesn't sync via iCloud

Hi!

I’ve got 3 mac’s, 2 iPads, and 1 iPhone syncing 2 databases and the global inbox via iCloud. I just noticed that the one Mac (it happens to be my newest addition, a MacBook Pro 16. Not sure if the makes a difference), is not syncing. I can add, move, delete a file on any of the 5 units, and they all stay insync. The MBP16 even if left to sit overnight never syncs. The Sync in preferences shows iCloud checked, the 2 databases and global inbox checked. It says Last Synchronization is a minute ago. Yet the database on the one machine is different. I connect the two of the Macs which happen to be on the same network via Bonjour and sync the rogue machine fine. But disconnecting that and just using iCloud it doesn’t update or update the other devices. I have cleaned the cleaned the location, cleaned the database, verified location and databases throughly. I have disconnected and cleaned the iCloud location and then reconnected, still no sync.

Next step?

I suppose you’re running Catalina and iOS 13.

Are you able to successfully verify the iCloud sync store on that machine (see contextual menu in Preferences > Sync)?

Yes, I can verify the location and each database and Inbox. None of it reports errors.

6:14:54 AM: iCloud Database “Inbox” successfully verified.
6:15:09 AM: iCloud Database “Scanner” successfully verified.

Correct on both points 10.15.2 on all Macs and 13.3 iOS and iPadOS

What exactly is different on the machines?

What’s different - anything I add, delete or edit. I can sync up everything using a bonjour connection. Then if I disconnect that the rogue machine doesn’t get updated while everything else does.

It is quite possible iCloud has stalled - a condition over which we have no control, nor can we even detect it. We can’t reproduce this issue, and some have said it “just started working!”

Here are a few things people have said “worked” , though we obviously can’t test it since we can’t reproduce it. I would try them individually, starting with the simplest…

  • Reboot the problematic device(s).
  • In DEVONthink’s Preferences > Sync , disable the iCloud location and quit the application. Relaunch DEVONthink and re-enable the sync location again.
  • In iOS’ Settings > your Apple ID > iCloud, try disabling and re-enabling iCloud Drive and DEVONthink.
  • In iOS’ Settings > your Apple ID, sign out of iCloud and sign back in.
  • In macOS’ System Preferences > Apple ID > Overview, sign out and back in.

Thanks.

I’ve got pretty far down that list: having done #1, 2, 3. I also sync my desktop and document files with the other devices and that seems to be working, indicating iCloud isn’t stalled.

I also sync my desktop and document files with the other devices and that seems to be working, indicating iCloud isn’t stalled.

That’s inaccurate as the behavior of one facet of iCloud doesn’t necessarily affect the behavior of another. iCloud in Catalina and iOS 13 is a mess (not just just us but for many users and developers). We have seen reports of photos and messages syncing fine but a new note in Apple Notes not appearing on other devices for up to 8 days!

Hmm, didn’t realize that the granularity of the iCloud sync. I assumed if one aspect was syncing, it was “on”. Any info on why you think just one aspect of one device isn’t working with iCloud? I sync messages, photos, notes, desktops, documents, contacts, safari bookmarks, calendars, 1password files on 6 devices and everything but Devonthink 3 syncs on every device but one.

iCloud is pretty much a black box in ways. And just as it is with one car versus another car, the performance of one is no indicator of the performance of the other.

Did you sign out and into iCloud? We cannot reproduce any issue at will, but based on support tickets I have, that has seemed to work fairly commonly (and again, this is a sporadic issue, so “commonly” doesn’t imply frequency).

iCloud is most certainly a total mess at the moment. I have had the thing stuck on uploading a 7KB file for several hours, and other files that have taken days to update. This utility might help to understand what is going on https://eclecticlight.co/cirrus-bailiff/.

1 Like

Problem solved. The rogue Mac had Optimize Mac Storage checked. Unchecking and it’s now syncing. The computer has a 1TB SSD w/ 700+ GB free so I’m not sure why it was trying to save space? Posting this in hopes it says someone else from pulling out their hair

Screen Shot 2020-01-30 at 6.05.18 AM

1 Like

Thanks for the follow-up. :slight_smile: