OpenAndSavePanelService freezes and uses substantial CPU (~88%)

For the last some weeks a serious issue has emerged on my Mac Pro (trashcan) server running the current (10.15.5) and penultimate (10.15.4) versions of Catalina . This is a systemwide issue and affects all applications, so not specific to DevonThink. Nonetheless, it’s impact on DevonThink is severe. When using the OpenAndSavePanelService top open or save files the service freezes for 20–30 seconds after briefly working (~5 seconds). Eventually, whatever is blocking the service resolves itself and the file dialog works as expected. The issues affects all software that use the OpenAndSavePanelService but not software using other file open and save dialogs., eg. the GIMP and Blender. This is perhaps an Apple issue however, it impacts the usability of DevonThink. I was under the impression that Catalina 10.15.5 solved this issue, but alas, no. For what its worth, my system has a Aura Pro SSD startup disk, two Thunderbolt-connected Mercury Elite Pro dual drive enclosures (one raid, one not), a usb 3.0 backup hub, and 64G memory. From time to time the file issue seems to contribute to system crashes which does cause problems with my DevonThink databases. Here’s a screenshot of the hung process.


Never seen that here.

Have you contacted Apple support about this?

Just posted on their forum and will try to call tomorrow.

Are you seeing this even when you’re not using the Open and Save dialog?

No. The freeze is specific to the service. Open Recent works as intended. Any kind of maintenance interaction with databases works correctly. The issue appears limited to the file dialog.

When using File > Open Database, it spikes to 36% for a second then drops to 6.1%, then 0.7% here.

Mine spikes to 130ish % then drops to around 88%.

Does booting in safe mode by pressing the Shift modifier key during startup fix this? You might also check the favorites in your Finder’s sidebar which are also used by the save dialogs. Maybe there are some outdated favorites, e.g. to servers?

The issue doesn’t persist in Safe Mode. The issue persists across computers in my case - both of my iMac and a MacBook Pro.

I’m seriously unhappy with the support here - this being a critical issue, all I get is a 1 per day email, one of which asks to reboot in safe mode, even though I’ve provided the detailed explanation and diagnosis of the issue in my first email.

Remove DevonThink, remove finder preferences file from: /Users/username/Library/Preferences/

The problem reappears as soon as I reinstall DevonThink.

Edit: the issue doesn’t persist in safe mode

I will see if the issue persists in safe mode in my case and let you know. There are no outdated favorites entries, so that does not seem to be an issue.

Is DEVONthink’s inbox part of the Finder’s sidebar? Does removing it make a difference? That’s actually the only DEVONthink-related item in the Finder’s sidebar and Open/Save panels (and in the end it’s just an alias).

DT Inbox might be the culprit here. What would be the best way of completely removing it from the system?

I think I was able to use DevonThink on the new user account on my machine without any issues (Save Dialog issues included), before installing the Inbox add-on. Not really sure anymore, as I removed and reinstalled it a couple of times already, trying to find out a way to make my machine usable again.

Removing it from the sidebar should be sufficient, otherwise delete the Finder’s preferences too (~/Library/Preferences/ and restart the Finder. Afterwards disable the option in DEVONthink 3 > Install Add-Ons…

Same behaviour, unfortunately. As soon as I launch DevonThink on the machine for the first time after removal and deletion - the problem reappears. Same behaviour on 2 different machines.

Is there enough RAM available while DEVONthink is running? DEVONthink is just an ordinary app, it shouldn’t have any impact on the system or other apps. Did you disable the option in the Install Add-Ons panel?

The problem persists while DevonThink is running or not running. There is enough RAM available. The option is disabled in the Install Add-ons panel.

I understand that DevonThink is just an ordinary app, with the only difference that it is the only app that renders my computer hardly usable in situations when you actually need to save a file :slight_smile:

An app that is not running is just like any file on the disc and the only thing it does is to require a little disk space. In addition, the Open & Save panel service is an internal, stand-alone & sandboxed process of macOS which DEVONthink (or any other app) can neither control nor customize.

Is there really no inbox in the Finder’s sidebar? Because that’s the only thing related to DEVONthink but even then it would be a bug of 10.15.5 as it’s just an alias of a folder - no extension, no driver, no hack.

But as the issue doesn’t persist in safe mode, it’s most likely related to a third-party app or extension that is loaded on startup. Did you install/update any software recently on both machines?

Yes, there is no inbox in the Finder sidebar

Apart from the 10.15.5 update and the latest DevonThink update - there was nothing installed. Apart from this, due to the pandemic, my MacBook was sitting idle since beginning of March. I noticed the same behaviour only after I tried using the laptop when the problem appeared on my desktop.

Do both Macs use the same version of macOS 10.15.5? Anyway, you could create a sample of the frozen service (see Activity Monitor > View > Sample Process) and send the result cgrunenberg - at -

Sent it to your email.

FYI, this is how it looks: