Opening a DEVONthink link in DT but from a web application

I’d like to insert DEVONthink item links into certain web-based applications (Notion, Roam) and be able to click on those links and have them open up the corresponding document in DEVONthink. However, when I’ve tried to do that, those links always get treated as web URLs to non-existent web pages that my browser tries to open.

Does anyone have a workaround for this? I have Alfred and Keyboard Maestro, so if you think either of those applications–or just some Applescript–would work well, please let me know (please also know that I am still VERY much a novice when it comes to KM and especially Alfred and Applescript).

Thank you for any help you can provide.

Works here. Roam Research:

Enter link like this:

Generates this view:

When the link is clicked, Safari requests this permission:

Perhaps you have a content blocker problem?

Right you are! Thank you. Probably I should have tried it in Roam before writing my message. I’ve been having the problem in Notion and thus figured I’d have the same problem in Roam. Notion remains a problem, both in Safari and Chrome. So if anyone knows a workaround for that, please let me know. Thanks again for the help.

Following! I just started out with Notion thinking this would work. But it doesn’t — and I want it to!

You should talk to the Notion team about this.

1 Like

According to Mark Robertson in the Roam FM podcast episode below, Roam is an outlier in terms of web applications that open up callback URLs. He says that one of the things that sold him on using Roam is precisely this feature. He also talks a little bit about how he uses Roam in conjunction with DEVONthink.

really want to know how to fix it ! use devonthink as my documents managers ,and i can refers to it anywhere !

Welcome @extirpate
Have you talked to the Notion team about this?