OS X Lion support?

Hi there!

I know, it’s a little bit early to ask for this, but what about OS X Lion support? Will this work without any problems when it’s launched (or does it already work with the developer previews), or do we have to wait with an upgrade to be sure to have working DEVON programs?


I’m afraid that this is a ‘chicken or egg’ question for the developers.

They have been working with the developer releases of Lion to prepare the DEVONtechnologies applications for the new operating system.

The developers received a new prerelease version of Lion this week, and Apple indicates that the public release will be made in July.

Great! But what if Apple makes changes from the last release provided to developers before the public release? Surprises could happen, and have happened in the past. Apple changed some text code in Leopard during the period between the last developer release on 17 September, and the public release of Leopard a few weeks later.

I’m looking forward to Lion, and will update one of my Macs to it as soon as the public release is available. But I’m going to keep one of my Macs running Snow Leopard for a while, so that I can keep on working with my DT Pro Office databases without worry.

Apple has a great reputation for quality control in new releases. But looking back at the past, the “.0” upgrades have had potential issues that got corrected in subsequent updates. For example, when Snow Leopard was first released, some users who switched to a Guest account and back found that they had lost their entire Documents folder content. Things happen.

Old hands often advise waiting a bit to see what happens to the early adopters. :slight_smile:

As always, backup before diving in to a major new computing environment.

Unfortunately, I may be that guy. The SMART Status on my computer’s hard drive has been “failing” for months now, and I’m hoping to hold on until the “back to school” promotion in the fall to buy a new computer. (And yes, the check engine light on my car is on. How did you know?)

Roaring Apps lists ABBYY Fine Reader Express as having issues with Lion. I hope it’s just that version.

Hmm, I suppose I’ll have to try it. Fortunately, I have an extra DTPO license floating around. (Why? Well, I was going to share stuff with friends with the web server, but they weren’t interested, so until I can get my wife on the bandwagon…)

FWIW, I tried opening DTPO on Lion, and both it and the built-in ABBYY seemed to work fine. I didn’t extensively test, but there were no glaring problems.

I just installed OS X DP4 on my MacBook Pro last night, doing an in-place upgrade. Only issues I’ve run into are that HyperSpaces and TotalFinder are incompatible but I expected that.

This morning, my Fujitsu Scansnap S1500M arrived. It scans like a champ (and hoo boy is it bloody fast) into DTPO on my Mac Pro running 10.6.7. Unfortunately, it’s not the same with my 10.7 install. It seems to scan and analyze properly but after you fill out the detail box, DTPO fails to import the scan. The log window is incredibly helpful by telling me the error is ‘Failed’. I’ve looked at the PDF with Preview and it appears to be fine. The same document scans and imports without a hitch on my 10.6.7 machine.

I’ve also noticed some issues with the DTPO Safari Extension. I tried to import an image and DTPO crashed after I filled out the import box.

I’m doing more troubleshooting presently.

This doesn’t make much sense. I can import a PDF as long as it’s already been OCR’d. If I try to scan or import a PDF that has no OCR information, it won’t go (regardless of how DTPO’s Preferences are configured). However, if I attempt to scan a document even with OCR turned off, the input fails. The Fujitsu scans the document but DTPO fails on import. As long as that document has no OCR info, and DTPO is set not to convert the document to a Searchable PDF, it imports. As soon as it tries to do OCR, it fails.

Now, if I let ScanSnap Manager do the OCR, DTPO imports it with no complaint. Thus, I’m assuming there’s an issue not with importing scans from the Fujitsu but in performing the OCR. So, it’s probably the fault of the version of ABBYY that’s installed with DTPO as the version installed with the latest ScanSnap version seems to work (and the version that DTPO has works in 10.6.7).

Hope this is helpful to someone.

I’m very happy to post that the update to Lion DP4 that was released today seems to have fixed the incompatibility with ABBYY. Scanning is working like a champ!

Just for your info: It wasn’t an issue of Abbyy. A bug of Lion’s PDFKit framework crashed the DevonThinkHelper and therefore the import of some PDF documents failed.

That’s good to know. I drew my conclusion based on how Roaring Apps had rated ABBYY. I’m just glad that it’s working now.