Paperless office System Converting to Apple Silicone

Hello All,

I have been using Devonthink Pro for a number of years with a ScanSnap i500 and an Apple MacBook Air. It has worked like a dream.

I have recently upgraded to the new Mac Air with the Apple Silicone and have run into some problems.

I had to upgrade the software and firmware on my i500 to ScanSnap Home - but that seems to have solved my scanning problem.

Devonthink pro 3 appears to work OK with the Apple silicone.

Acrobat Pro would not open until I upgraded it to Acrobat PRO DC - which I did and it will now open as stand alone.

The problem is with OCR and creation of the PDF. When I scan to Devonthink - I receive a message incomparable processor type. I’m thinking the scanning software is not connecting to the new version of PRO or the OCR engine.

Can anyone help with how to resolve this problem. Thanks in advance

1 Like

A screenshot might be useful. In addition, did you install Rosetta? It’s not installed by default on Big Sur.

Thanks, I’ll screenshot it when home tonight and yes Rosetta is installed. Thanks for your response.

Thanks for raising this - I’m still using an Intel processor (and Catalina), and I also use an iX500 with the 64-bit version of ScanSnap Manager (which I prefer to ScanSnap Home) to scan directly into DT, complete with OCR during PDF creation. But I’ve been tempted by what I hear about Apple silicon performance. Let us know what you find out.


Here is the message I get. Scanner works, DT2 opens and then this pops up.

You said you were using DEVONthink 3.

OCR does not work in the deprecated 2.x line in macOS Catalina and later.

Correction Typo on my part DT3

But the screenshot is definitely one of DEVONthink Pro Office 2, not DEVONthink Pro 3. Are both apps installed?

You are absolutely right - ScanSnap was opening Devonthink 2 as it was still installed. I went in and changed the settings and it is now working as expected. Your comment sent me on the right track to figure it out. Thanks

You should not have DEVONthink 2 and 3 on the same account, on the same machine. At a minimum, delete the 2.x application from the /Applications directory and reboot the machine.

Will do. Thank you.

No problem.