Passing Tags via createText URL Scheme Creates .adb file

It appears when passing tags through the URL scheme, the file format of a plain text note changes to .adb

For example, when I use this URL to create a plain text note in DTTG from Drafts:


Everything is passed correctly, title, body, and tags are even assigned. But when you check the file format (NOT KIND) in DEVONthink Pro Office via the Info panel it shows as .adb.

If I take that same URL and change it to createMarkdown, the Markdown file it created correctly with the correct file format of .md

I’ve also tried the URL as the following with the same result results: (In line 2 would be: tag1,tag2 Both are passed correctly but the file format is incorrect.)




Again this only happens with the createText command. This was originally found by @chrome in

I have reproduced this but am uncertain where the fault lies.

I am curious though… why are you creating plain text files instead of Markdown?

I usually create in Markdown, but the person over in the Drafts forum was using an action that was creating a plain text file, so I changed my action to create the plain text file. That’s when that person noticed the issue, and I was able to reproduce it.

The only other reason I use plain text instead of Markdown is if it is only a URL in the text of the item, or a URL I frequently visit. I’ve found I like the plain text tap the URL and it brings you into Safari, whereas in a Markdown file when you tap on the URL, it opens in the DTTG in-app browser.

If we could get an option to toggle opening all URLs in Safari that would be awesome and eliminate my need for plain text files.

To add to this I noticed that the .adb is created every time, even if you use actions that do not encode tags.


This one, without tag encoding creates an .adb too.

Only through the share sheet I can get a .txt.

When you use such a URL from another app, e.g. Workflow, does it also create an .adb file? We’ll look into the issue presumably tomorrow (today’s Labour Day here in Europe).

Hello Eric

Sadly I am not very proficient in using workflow so I can not help you with this question. But I wondered too. I tried the URL used by 1writers action director in drafts and I got the same .adb. But of course the file was sent again by drafts because I do not own 1writer.

This happens with drafts 4 and drafts 5. I tried both.

Schönen Feiertag!

Workflow at least sends it over correctly.

I’ll check 1Writer in a little bit when I’m at my iPad.

Excuse me about the previous post, I didn’t add tags to the Workflow so it passed correct. Once I added tags to the URL the tags are passed correctly but the file format is changed to adb.

I was also able to re-produce this in 1Writer.

If I take out tags from the URL the file is txt.

Okay, thank you! But this is strange, because even if I use the “normal” action supplied in drafts (4 and 5) by agile tortoise I get an .adb every time. There are no tags encoded here…


I tested this multiple times and I get an .adb every time. Never ever I managed to generate a .txt with any of the actions in the action directory of drafts. Only the markdown action provided by JCSully217 works correctly and produces a markdown document.

Thank you for investigating so thoroughly! We tested with Drafts and Workflow and were able to reproduce the issue. DEVONthink To Go simply selects the wrong file name extension from the long list of possible extensions for plain text documents. Fixed for verison 2.6.

Thank you very much for this fast response and fixing this!