Pasting Images

[ First a point of confusion. When I enter the forum here online via DT, I peruse the list, I click on New Post, it takes me to a login screen, I click the my login info is automatically provided me, I click the go-ahead.

it then tells me I’m logged in and takes me back one screen to the login screen again. This I can repreat 20-30 times if I like or jump ahead of the game and manually click on “return to previous screen”. Inexplicably, sooner or later, it will provide me an opportunity to enter a question, like this. Man-oh-man, I don’t get.

Sometimes I click the “log me on automatically” button, which changes may interaction not one whit. The next time I attempt to join the forum from DT, it again lets me do what I like until I want to enter post a new message, whereupon we get into the login loop, and I note that the “auto login” option is again unchecked. ]

My real question (which I’m too nervous to try to put in another post, is this:

I snatch a piece of an image in a program (Logic), go to DT and use to be able to simply paste my paste-buffer in; bingo I have an image as my newest entry in the home folder. in DT2, I issue the pretzel-V to paste, nothing seems to happen. Or, I can go to Data > New > With Clipboard and also nothing seems to happen.

How to I paste images into DT2?

– Gerry

Cmd-N or Data > New > With Clipboard should work and will paste the image into the current group (if DEVONthink is active and if there’s a main window) or into the global inbox.

Sorry: I misspoke when I said ⌘-V, I actually used ⌘-N, and also attempted the drop-down: Data > New > With Clipboard. Neither worked. I was beginning to think it was a problem with Logic or something it did with the buffer and so attempted it with a piece of an image out of GraphicConverter. Neither worked.

Today both work, perfectly and with no hesitation. That’s strange. For the moment–no problem!

– Gerry

If I could join in…

Jerry’s method didn’t work for me. Neither does drag/drop into Sorter.

I’m trying to capture a part of a web page, with images, and yank it in. The actual material as opposed to linked material.

Drag/drop to sorter just gives me text and no image.

I’m sure there’s a way to do this easily, but I’m stumped…



Just a quick addendum.

I was able to do it in the regular DevonThink 1.X – there was aclipping icon on the app toolbar --although I can’tremember quite how I managed it.


It’s really easy to select text and images of a Web page and capture it to your DEVONthink database either as a clipping (saved in the database via Command-N) or by drag & drop of the selection to the Sorter. Works every time.

That is, it works if you are using a Cocoa browser such as Safari, DEVONagent or the browser that’s built into DEVONthink. Apple has created a number of mechanisms for communication and interoperability with other Mac programs.

But it DOESN’T WORK if you are using a browser such as Firefox, which is not aware of important Apple mechanisms for communications and interoperability, such as Services. That’s not the fault of DEVONthink. Regardless of other good features of Firefox, I personally regard it as an unacceptable choice if the purpose of browsing is to facilitate quick, easy and flexible options for capture of information from the Web to my databases; my favorite capture mode, rich text, isn’t available and the other modes are much slower than they would be from a Cocoa-based browser. Compare, for example, the speed of capture of a WebArchive from Safari using the available Service, to the speed of capture from Firefox using a script. Instantaneous in Safari, DEVONagent, the DT browser. Lots of time for thumb-twiddling in Firefox, and lacking the option of capture of a selected portion of the page.

Now and then I see a rumor that the developers of Firefox will incorporate OS X Services (Camino can use a few Services, but not enough yet). When and if that happens – and especially if Firefox includes a good Applescript dictionary – it could become a super browser.
[/RANT] :slight_smile:

Okay, based on Bill’s rant I’ve started messing around with this again, trying to find out what’s up.

Opened a TIFF in GraphicConverter (v6.4.1), “copied” a bit of an image. Went to my DT2 database. Use Data > New > With Clipboard and “Picture 1” appeared in my home directory. I double-clicked to open it provided an image display window with grey content. Nothing to be seen here.

Did the exact same thing again. Got a “Picture 2” which displays the same, only know we have a large question mark in the image-display window.

Got “Info” on this item and I’m told where it resides (./pict/1/Picture.pict), that it is a image file of so many pixels and so forth. But doesn’t display.

Drug the image out of GC to the desktop and then into DT, same result. Drug it straight into DT. Same result.

Tried all this with an image from Safari. Works just fine.

Copied/pasted from Evernote. Doesn’t work. Drag and drop does.

Neither copy/paste nor drag/drop is recognized with Illustrator.

My initial confusion was over the use of clips from Logic. It works fine with Data > New > With Clipboard instead of a straight paste–which is just fine as long as it is predictable.

– Gerry

Here we go again. :slight_smile:

I can replicate your experience with copying a selection of a TIFF to the clipboard and using Command-N to save it into a DT Pro 2 database. Result: a grey image displaying a question mark. Actually, though, I can reconstruct that image by using Open With to GraphicConverter, then saving the selection to, e.g., the Desktop. If I then import that file to DEVONthink, the image is displayed as expected in the database.

Want to capture a selected portion of that TIFF image by copying the selection to the clipboard and choosing Command-N in your database? Open it under Preview, choose the Selection Tool and copy the selection to the clipboard. In DEVONthink, choose Command-N. There’s the image!

Back to my rant, Preview is Cocoa-based and tends to handle images and selections of images in a way that communicates well with DEVONthink. Although GraphicConverter displays entire images that can be dragged and dropped into DEVONthink, it behaves differently than does Preview for handling Copy of selections of images.

So if I wish to crop just a portion of an image to my DEVONthink database, I will get the results I expect from Preview or Aperture. If I wish to copy rich text including images from a browser, that works with Safari and other Cocoa-based browsers. If I wish to capture text and images from a word processor display, I’ll get that result from a Cocoa-based word processor, but not from others, such as Microsoft Word.

Interoperability is an important consideration in my choice of applications to perform tasks.

I use GraphicConverter for other reasons, such as its ability to do batch processing of image files or to browse through my latest folder of photos and delete the ones I don’t want to keep. But I wouldn’t choose it to crop a selection of an image to be sent to my database; I would use Preview to open that image and make the desired selection.

Thanks for your input Bill.

Why would I use it from GraphicConverter? I have images of the scan from a CD, and want to clip the image of each set of lyrics to be put into the DT2 database as a stand-alone song. There was another little mini-project I had in which I was clipping portions of images later to be pasted in at various points in a (number of different ) newsletters. I think DT is the perfect “housing” for this kind of thing: Do all the collecting of image resources at one point, from whatever varying locations. Then organize them in DT, and later call them out as needed in a final document in Pages or some such.

I’m a super-fan of the ⌘-) ⌘-( and ⌘-@ keys for collecting raw text material. I’d love it if I could do the same thing with images. That would be really cool and greatly appreciated. It’s a logical thing for DT to do, actually.

– Gerry


Thanks so much! You’ve saved me much head-scratching. Of course – I seem to recall having read about Cocoa, but promptly neglected to think about it.

I’ve taken the time since you wrote to do some testing – it all works exactly as you say!

Thanks also to Gerry for jumping back in on this thread.