PDF sidebar edits in 2.9.6 under Sierra 10.12.1

The release notes claim that PDF sidebar page delete is fixed for 2.9.6, but although the context menu choice for delete page is back, it doesn’t work properly. The selected page icon disappears but the change is not permanent.

Under 10.12.1, the following Swift code snippet works as expected, so it looks like this could be on your end.

let myPDFfileURL = URL(string: “file:///Volumes/Master/Projects/PDFKitTest/testpdf.pdf”)
let pdf = PDFDocument(url: myPDFfileURL!)
pdf?.page(at: 1)?.string // outputs the text of the second page
pdf?.removePage(at: 0)
pdf?.page(at: 0)?.string // now the second page is the first page so the delete worked

Similar issue here (macOS10.12.1 & DTPO2.9.6).

PDF opened in separate windows, cut page-icon in side bar => page is deleted, but page-icon is still there.

Same page cannot be pasted within same document and drag&drop of page-icons is also not working.

Issue is reproducible with different user-profile.

Some of the many bugs in Sierra’s PDFKit code are still being addressed.

See Help > Release Notes, especially PDF issues.

Did you cut/paste the last page? That’s a bug and will be fixed by the next maintenance release.

Christian, it was the last page that I tried. Just tried it for non-last page and it works ok.
– Steve

A complementary question: on pdf sidebar the page number is missing?

Yep. There’s many things we’ve had to fix and even build from scratch due to Apple’s changes. More changes coming.

Thanks for the clarification.
The amount of problems related to the pdfkit are incredible… :imp:
At this moment, for example, it’s impossible to work with the Excerptor.

The next maintenance release will fix this finally too.

You’re not kidding! This was a fundamental change Apple made, and yes, it has caused hell for more than just us. sigh

Yes, I noticed: others apps with pdf viewer presents a lot of problems…
I just can desire a good work on workaround this “sierra” (mountain) problems…

One more question: If I create a note/comment/… on pdf file (on DTP or other app), on DT database I can’t preview that comment/note? (On pdf preview just appears the icon and to see what is inside I need to open the file in separate window, activate “select”, double-click, activate de “annotations” pane and finally see the note/comment. This is the normal behavior?)

Well, not really normal - seems to be another regression of Sierra.