PDFkit issues? Most pdfs not rendering, capture crashing DT

Hi team,

I’m on DTPro 2.9.11 and Sierra 10.12.4 (as of a couple of days ago) and now I notice most pdfs do not render… see image (sorry for not resizing it)

Also, using the Chrome DT capture extension and saving as pdf consistently crashes DT.

I suppose its the kit again, correct?


Addendum: NO PDFs render, at all, no matter the group, no matter the database.

If I dbl-click to open the pdf in its own (DT) window, still no rendering, just a blank page.

Can’t browse my pdfs anymore. I now have to launch an external editor every time.


As you know, Apple slashed and trashed PDFkit when Sierra was introduced and has not yet fixed it, and perhaps will never manage to fix it – or even care to fix it.

10.12.4 is not an improvement.

Anyway, this has been discussed here in thread after thread for most the past year. DEVON has made heroic efforts to overcome the limitations. There is no end to the madness :mrgreen:

Personally, I use Acrobat DC.

korm, does this mean you are using DC to view any and all .pdf files inside a database, as in not even asking DTPO to render a .pdf in the first place? I only ask because this issue is affecting me as well and am curious to learn how others are coping.

No. I strore and view maybe 50% of my PDFs in DEVONthink. Just preview. Everything else, edit or annotate, is in Acrobat.

Interesting. Thanks. I go back and forth between Skim and Preview, but own Acrobat 11. Have been thinking about upgrading to DC.

Korm, I wish I could preview mine as well. I can only see the thumbnails. What can I do?

BTW, not criticizing DT here, they have been heroically dealing with this - but they’re not the only ones that suffer the consequences, I have other (much less important to me) apps that also use PDFkit.


Ah - yes, I read this tidbits article tidbits.com/article/16966, my apologies as it must have surely been posted here before. It does hilite our brave DT team, as well as a few other notable developers.

C’mon Apple.


If you’ve been using 11 for annotation, then I wouldn’t upgrade. DC has more document management features, but the basic stuff is pretty much the same as in 11. Save your money and go see a good movie :laughing:

For me, the problem raises its head only after I try to view one particular PDF.

After I’ve tried to open that one, then no other PDFs will render (they are all blank). But if I quit and restart DT, then the problem is fixed, at least until I touch that one again.

FWIW, that particular PDF fails in the same way in Preview.app and Papers.app as well (no surprise). I can view parts of it in Safari, and all of it in Acrobat.