Permissions Issue Accessing Mail Script

I set up a new User Profile on my Mac and I want to get the Save to Devonthink mail script working.

I have the Automation permissions set up:


When I run the script, it fails with a briefly flashed error which I think has to do with permissions but cannot read quickly enough. But I do note that after the attempt to run the script the privileges have changed:


I re-enabled the privileges, rebooted, and tried again - same results.

Thoughts on why?

Does Mail and DEVONthink have Full Disk Access?


When you run what script?

When I run this from Mail


What is reported in Window > Log?

In Mail, there is no Log

In DT3, the log is blank

I should add that when I run the script the first time the DT3 permissions disappear for Script Menu. If I run it again the Mail permissions disappear. If I recheck them both, the cycle repeats.

Why would permissions like this disappear or get unchecked without my doing it directly?

You appear to be describing something unusual here.

Solved it

I was setting up the new User Account via Microsoft Remote Desktop and for some reason some popup windows asking for approval to activate permissions did not appear that way (or maybe were blocked due to the screen resolution).

1 Like

Glad to hear it.