Please help! Devonthink and cloudmount

*I’m not good at english, sorry about that and also thanks

  1. I’m using onedrive and all my files are in it.

But videos and music are not in there because devonthink blog says don’t use devonthink as a junk drawer. but still my file is very big because i want to fusion between several scholarship.
so my research and school class files are in onedrive

  1. Onedrive is mount in mac by app named cloudmounter

because i have only 256gb mac and actually can use under 40gb, cloudmounter does not mean, it is different.

  1. I use indexing file from cloudmounter

It run well. I can index all the file in onedrive

  1. problem 1 : when i delete file on devonthink but not delete in mounted onedrive

so when i click ‘updated indexed item’, they(file before i delete) came back to devonthink

In this time only i can do is click ‘show in finder’ and delete file myself on cloudmount onedrive file on finder

  1. problem 2 : When i create file on devonthink (such like rich text or group folder), it doesn’t sync at cloudmounter’s one drvie.

Well… create like such format and name like ‘New rich text’. I take a screenshot about it. (explain: i create a group folder and rename ‘test’ but on cloudmounter’s onedrive, folder’s name is just ‘New group’ , I want to rename and sync at cloudmounter as well.)

  1. If you recommend me not to use cloudmounter, My situation is like this.

I’m student and I don’t have much money so i only choose one of them. > icloud 1tb or Onedrive 1tb & office 365 (dropbox is too expensive)

and i have m1 Macbook air. It have 256GB and can use under 40GB from now on

my files are total 200GB they include my school studies, my interest research.
(I study computer science and interest in movie, fashion, self growing, philosophy ect.)

  1. Thanks for reading and your kindness.

I know that i have bad english. but i real want to use Devonthink for my creativity and knowledge.
I want to thank you about reading this and write comments about this write with strange english and Requirements.

1 Like

Did you empty the trash and choose the option to delete indexed files on disk too? Otherwise only the reference is removed from the database when emptying the trash and File > Update Indexed Items indeed adds the file again.

Did you create the new item in an indexed group?

1 Like

yes i did.

When i empty trash, in this option i always choose ‘Remove all items’

Yes i did. I take a picture when i make a rich text.

First i make rich text named ‘New Rich Text 1’
and i rename ‘test’
and click ‘show in finder’
but in finder i can only see ‘New Rich Text 1’

  • ‘test’(in devonthink) and ‘New Rich Text 1’(in finder) path is same

  • when i write some text in ‘test’ it applied at ‘New Rich Text 1’ Immediately. So i think that the problem is only occur when i rename

I’m not seeing any issue with creating a file and renaming it (without editing the content) in an indexed OneDrive group. The renaming is shown in the Finder as well.

1 Like

In the picture

When i rename ‘New Rich Text 1’ to ‘test’ it works at devonthink
but in finder, it just still ‘New Rich Text 1’
(editing the content is works well)

Something i missing?

As long as it’s not a permission issue, it might be caused by cloudmounter.

1 Like

I also think cloudmounter is the caused.

Can you recommend how to use devonthink without cloudmounter?
and also i don’t want to use many of local ssd in my M1 Mac air
Only way to solve this problem is using dropbox?

This is my situation.

Do you actually plan to index the complete amount of data? DEVONthink requires local copies for indexing and tries to download everything which isn’t yet locally available.

1 Like

Yes, i want to index the complete amount of data. Also i did it with cloudmounter. (How can i did it with cloudmounter without local storage? > First mount it when devonthink indexing and when storage is almost full, I quit devonthink and disconnect the mount. Second remount the onedrive with cloudmounter and start the devonthink. Then the devonthink indexing again the file which left behind)

Why i want to complete all the data.
I’m not trying to use devonthink as a junk drawer
Only i want is connect different studies.
(For example connect social science and art.)
To do this well, i think social science and art should be in the same devonthink database to search well.)

This is my folder. I want to know many things, so i classification things with DDC(Dewey Decimal Classification) that is why my file is very big. And it will be more bigger.

I buy devonthink because this reason.
But cloudmounter will be never work and Devonthink must requires local storage for the data. I will consider another way.
But i don’t want to give up using DDC.
Can you recommend another user’s examples?
And also using DDC with Devonthink?

Any reason why you are not importing these files? Do you really need to keep the files outside of DEVONthink for some other use? Importing is more secure/reliable than indexing especially with folders that are synced with external servers.

1 Like

I don’t have much storage in my Mac

And also i want to Access these files at windows and another mac.

I think so too. cloudmounter is making problem. but i think i don’t have many choices about this.

This is what i must want.

  1. Access file at other computer
  2. Using DDC in devonthink

Thanks for your reply!

Well, for lots of reasons, your MacBook is seriously under-powered to work with DEVONthink with your data requirements.

1 Like

Yes… that’s makes me sad. All i can have is 256 mac…
When i buy it, i think cloud service will solve this problem.(so sad…)

Yes, from reading the Apple marketing blurbs, for machines with little disk space, Cloud services to take files “offline” probably can seen to help.

But DEVONthink needs more disk space for your data requirements, even if files that you index are “in the cloud”. There are technical reasons for this, but … it’s just the way it is.


Thanks for reply!
I think that i almost success because devonthink indexed well in cloudmounter but the delete and creating file doesn’t work… it is strange because editing the file works well…

I will find out more. Thanks for reply! Have a good day!

Just wondering but why don’t you use the official On the latest macOS versions it supports removing of local copies etc.


If you don’t need the data in OneDrive, why not get a sufficiently large portable hard drive and put your databases on it? They’re small and relatively inexpensive now. You can easily get a 2-4TB drive for a good price nowadays.


I was stupid. I just get recommed to use cloudmounter by someone who using devonthink and post about devonthink at the blog. And also i didn’t know onedrive supports removing of local copies as well.

Now i’m indexing with It almost seems be going well. I check create, delete, editing the file and also rename and move the file as well.

I think it almost solved the problem. Thanks a lot.
Now i just waiting the indexing done.

1 Like

I will buy portable hard drive to for the backup my files. But still i will use onedrive for access the file everywhere.

Thanks a lot. I think my problem is almost solved. I’m so happy!

1 Like