Pls enable highlighting of bulleted lists in Markdown


just came across a minor issue with highlighting in markdown documents.

In a bulleted list, it’s only possible to highlight the contents of one bullet at once. If I select text from more than one bullet, the markdown syntax for highlights is not “translated” into the highlight in the preview, but shown as symbols.

A screen capture would be helpful.

Here’s a quick screen recording that shows what I described:
Screen Recording (9.2 MB)

Following up on this @bluefrog. It does seem to be a bug, doesn’t it?

The fact that it inserts the highlight control characters is a bug.
But what you are doing in incorrect and not supported in Markdown or HTML anyways.

See this in MultiMarkdown Composer (which also supports CriticMarkup)

The only way to do what you’re attempting, i.e., highlighting the full ordered list would be to create the list manually, like so…

And in DEVONthink…

@cgrunenberg : I think the Format > Highlight command should be disabled if more than one line in an ordered or unordered list is selected in the Markdown source. Or perhaps you could apply the control characters to each independent line, but that’s for you to determine.

The next release will apply it to all lines.

@cgrunenberg @bluefrog You probably hear it a lot, but the level of responsiveness and the pace at which potential improvements are implemented here really is extraordinary! Thank you.


Thank you for the nice comments :slight_smile: