Poor search-while-you-type performance

Hi, all,

Is there a way to disable “search-while-you-type” functionality in DT Pro (2.0.9)?

I have a reasonably large database (7.6 GB) and I get the spinning beachball a lot when typing search strings. As a workaround, I cut and paste search terms from outside the application, but I would prefer to have my DT searches begin only when ‘enter’ is pressed.

I do not want to disable search-while-you-type systemwide, since Spotlight performance is fine. It’s just DT that is glacially slow (I even rebuilt the database and that didn’t help).

I’m not working with an old or underequipped machine (2011 quad-core MB Pro w/ 8 GB RAM). It’s exceptionally fast–except when doing DT searches.

Thanks for any help,
Joe

See: Searching in Devonthink

Ah, so simple! Thank you very much!

Same issue here with DT3, but the link sends me to a 404. Any option to turn this off in DT3?

See popup menu of toolbar search field.

This is covered in the Help > Documentation > Windows > Main Window > Search Pane: Search Options

Thanks. Missed that one.

No worries!

Current link to that +9-year-old topic: Searching in Devonthink

1 Like