Problem sharing PDFs between DTTG and PDF Expert

Please help me. My workflow no longer works. Maybe this has something to do with updating to the latest version of iOS? I urgently need to find a solution. Please help me.

I organize my PDFs in DTTG. To read a PDF and annotate it, I use PDF Expert. So far this has always worked well. In DTTG I have selected the PDF, I have selected “Share”. The PDF was opened in PDF Expert, I annotated it there. When I was done, I’m on “Share” in PDF Expert, selected DTTG there. Then DTTG opened automatically and showed a message “Object actualized”. That doesn’t work anymore. If I want to actualize the annotated PDF to DTTG, to apply the changes, a copy is always copied there, but not the old PDF actualized. When I select “Share” in PDF Expert (and as always before file format “Original document”), then DTTG, a selection “Clip to DEVONthink” appears. This selection window “Clip to DEVONthink” never appeared so far, the PDF was simply actualized instead. When I use “Clip to DEVONthink”, a copy is copied to the selected location in my DTTG database. Since I have replicas of all PDFs, replacing the old versions with the annotated ones is very time-consuming.

Also new to me: When I select a PDF in DTTG and select “Share” in the menu that opens, there is a text character in the upper left corner next to the title of the PDF with cursor as symbol, when I click on “Open in…” in the menu, it changes to a PDF symbol. I don’t see the difference for “Sharing”. But regardless of what I choose here, the problem described above always occurs.

I’m really asking for help. Hopefully my English is fine. I use the German UI. Many, many thanks!

Yes, this is due to changes in iOS 13. We have not yet found the cause or a workaround, we’re afraid.

Thank you very much for the narrow answer. For me this is a catastrophe and brings with it a financial loss due to the increased expenditure of time that I now have. I am a professional editor. Can you please, please try to find a solution. In my opinion the smooth cooperation with a program like PDF Expert is really one of the most important features.

Today I tried to return to iOS 12 for twelve hours. Although I have a backup, not possible. If only I’d known what a functional limitation an update to iPad OS (iOS 13) would bring! Does anyone have a suggestion? A good workflow to work around the problem?

I am very grateful for any help.

The easiest workaround is to open files not via the Open In roundtrip but through the Files app. You can access all documents in DEVONthink To Go reliably through the file provider mechanism and save changes, just like you’d open and edit a PDF in iCloud drive from PDF Expert.