Problem since recent update

I recently updated DTTG on iPadOS following an App Store prompt. I presume it was to DTTG 3.7.5. On starting the new version it said it was updating the database, which took several minutes. The app then vanished (crashed?). Since then, the app appears very briefly showing the logo when started and then crashes.

I uninstalled DTTG (which removed the data) and reloaded it from the app store. It then started fine and I was able to set up sync with DEVONthink on my iMac (direct sync over local network). Shallow sync with two databases appeared to be working fine. When I turned sync on for a third database, DTTG crashed immediately. That database appears fine on the iMac where I have closed and reopened it. The database size is 36.5 GB.

The version of iPadOS is 16.6.1.

Do you have enough space left on your iPad?

Yes, 74 GB free and I tried to do shallow sync (metadata only) for a database which is 36,5 GB on the iMac. This database was syncing fine prior to the DTTG update.

Similar problems. Same config. As soon as an item is opened DTTG hangs completely

You should be reporting crashes to our support ticket system.

Thanks Jim, will do.

1 Like

Same problem with iPados 17.0.1 and iOs 17.0.2. Deleting the App, new instal same result. Crash and the App does not start again.

1 Like

Thanks for confirming this. I have filed a support ticket and I understand that the bug may be fixed in the next maintenance release of DTTG.

I’ve just submitted a crash report, but I specifically triggered the crash by using the share sheet so it might not be the same bug as reported here, though it sounds very similar.

To be honest, I’m also not entirely convinced it wasn’t the Highlights app that caused DTTG to crash as I’d not had any problems with DTTG and iPadOS17 until I tried to open a PDF externally. I am unable to troubleshoot it though as the share sheet button will no longer work even if I hard close DTTG (pressing it just crashes DTTG again).

I am also having problems with DTTG crashing on iPhone, iOS 16.7. Had the same trouble with 16.6. I see the DT logo for a few seconds then the home screen reappears.

From this thread I see that maybe the problem is lack of space on my iPhone? There are about 30 gigs of free space on it. Maybe that is not enough, and causing the app to crash?

1 Like

Were you previously running DEVONthink 2.x, especially the Personal edition?

Yes, I started with the Personal edition of DEVONthink 2.x.

Thanks. The issue should be fixed in the next maintenance release.

You mean, years ago? Maybe. But I have been running DT 3 on my Mac for a long time. And I’ve never had a problem with DTTG until a few days ago.

This crash should be resolved in the 3.7.6 release that came out last week.

Or maybe you meant what version of the DTTG app? The one I have is 3.7.6. If it was ever 2.something, it was a long time ago.

Looks like others have a similar problem and that a maintenance release will fix things?

Meanwhile, on my iPad, DTTG still works fine. My problem is confined to iPhone.

It was not resolved in my iPhone. I have the same problem today.

DTTG icon appears, there is a long pause while it stays on an otherwise blank screen, then, poof, back to the screen with all the apps.