Problem syncing after restructuring databases

I have restructured my original five rather unrelated databases into just four PARA databases (Projects, Areas, Resources, and Archives). Of my original five databases I renamed one into Resources and streamlined it extensively. I moved folders around, deleted a fair amount of others, and deleted some too, ultimately emptying and deleting each of the remaining four databases

Unfortunately, I now have a syncing problem which I hope will be fairly easy to correct. I use the Bonjour method, have always synced all of my databases and want to continue syncing all of the new four, bearing in mind that none of the four are extra large as yet. I use my iMac as the “server” and sync with my MacBook and iPad/DTTG. Now, when I try to sync I get messages saying essentially that the four old databases I deleted are not available on the server. The renamed and re-arranged Resources database seems to sync correctly but on both my Macbook and iPad I still see the old four deleted databases, three of which now show as empty, and the other one reflecting many changes I made on my iMac (the last of the original databases I worked with) yet it is not entirely empty. Can anyone tell me how to rectify this sync problem?

Did you actually “delete” the databases from within DEVONthink? Sound like, based on symptoms, you did not. Hard to tell from this distance.

Any reason you can’t now delete them on all devices, either in DEVONthink or with Finder?

Now, when I try to sync I get messages saying essentially that the four old databases I deleted are not available on the server.

You deleted the databases where?
As has been mentioned many times, we use and advocate a decentralized data model. Each device has its own copy of the database(s).

  • Deleting a database on one device will not delete it from another device.
  • Deleting a database on one device will not delete it from a sync location.

Thanks for responding, BlueFrog. I deleted them from my iMac, which I consider my primary device or “server”.

Yes, I deleted them from within DevonThink, rmschne, thanks. I suppose I can go ahead and delete them from my other two devices yet I’m very hesitant to do that without having a better understanding about how it all works. I’m still relatively new to DevonThink, like it very much so far yet know I haven’t really begun to learn all the many things it can do.

Just to be sure, should I proceed to delete the old databases in my two synced devices (MacBook and iPad) that I’ve already deleted from DT on my iMac. And will that simple task enable the syncing to complete and bring over the new databases to these two devices?

I don’t really think the existence of databases that you don’t want to exist have anything to do with not synching. From my seat here, seem like you are conflating two issues.

On the two devices you want sync with the “server” machine where Bonjour “Incoming Connections” switch is turned on, you still have to tell DEVONthink and DEVONthink ToGo to sync the new databases you created in the sync setup sections of these two apps. You are doing this and still no joy?

As you are a new user of DEVONthink, I’d recommend you make sure you have a handle on making backups, discussed in the “DEVONthink Manual” in the section entitled “A WORD ABOUT BACKUPS”. [Actually there is more than one word there, but all important! :wink:]

1 Like

Just to be sure, should I proceed to delete the old databases in my two synced devices (MacBook and iPad) that I’ve already deleted from DT on my iMac.

As I said, deleting databases do not affect other devices. So if you don’t want them, then delete them from all devices. And they’re complaining about syncing because you still have them on those devices and DEVONthink on the iMac doesn’t have them. So you’ve created a situation where a database is trying to sync to something you deleted. Nothing is amiss or awry here; just logical.

1 Like

Thanks for the good advice but I believe that I have the backup issue covered. In addition to Time Machins backing up to a separate harddrive, I also now use Arq 7 Backup, which I had not been aware of until it was mentioned on these pages in Community. I do like and so believe I’m now in good shape.

Okay, I have deleted all my old databases from both my MacBook and iPad so the only one remaining is Resources, an old database that I renamed and want to keep. That is perfectly in Sync. But I still haven’t been able to sync the other 3 from my iMac server to the other two. When I highlight one of them on my iMac and go to File/Sync Database it is grayed out. Same with the other databases. What am I missing or failing to do?

You can’t push a database via Bonjour. You can only pull one, i.e. import.
Look at these instructions again – Bonjour Simplified – and there is no pushing a database mentioned. Just follow those instructions as given.

1 Like

I hate to tell you Bluefrog but I’ve been working with the Bonjour Simplified and there seem to be a number of things that don’t seem right–Bonjour password not being accepted (and I know it once worked fine but that was way back when I first set up Bonjour), plus iMac server not seen from DevonThink. Again, I know it used to be there but now I see two, one for my MacBook and the other for the iPad. The Requirements Section all seems okay. When I get to the In DEVONthink, Check Enabling Connections is okay. Port is not blank but has been filled in since setup I believe. My Password is not accepted. Continuing in DT In Preferences>Sync that’s where I see the two wrong devices (MacBook and iPad) but the iMac doe not appear. I don’t find a checkbox to enable the connection as is instructed.I don’t see a list of the four databases on the iMac, only the one renamed to Resources which has been on all 3 devices right along and is perfectly synced. In brief, not much seems to be appearing or acting the way it should. I’m going to be out of town for a couple of days and hoped to be able to use DTTG on the iPad but doesn’t look like that’s going to happen (which I can live with). Will appreciate your further guidance in getting me out of this mess, but if it doesn’t happen before 5 pm today (and I’m not asking you to accommodate me as you obviously have many other important things you must do!) it will need to wait until Friday. Many thanks for all your help thus far!

You would not see either of these if Bonjour is disabled on those devices. And the iMac won’t appear to itself. It’s the server; it’s not the client.

I don’t see a list of the four databases on the iMac

Because you deleted the databases from the iMac, according to what you said previously.

Thanks again. There are four new databases on the iMac (including the Resources one that was Renamed and that’s okay) the three of which don’t appear. The old ones are now deleted everywhere, from DT or DTTG respectively). Also, I haven’t found any option to update the Bonjour password as that is still a stumbling block too. Incidentally, I have quit and relaunched on all three devices and have also rebooted my iMac. I’ll continue to try other things on Friday when I return.

Three don’t appear where?

In both the MacBook and the iPad. The only database now showing in those two is the renamed Resources one.

Assuming you have the databases open on the iMac…
With the Bonjour sync location selected on the MacBook, do you see the database(s) in the Remote section of the Databases list on the right?

There is no place, far as i know to update the Bonjour password.

On the MacBook and iPad, disconnect the Bonjour connect.

  • On Macbook “uncheck” the Bonjour connection in Menu → Settings → Tab: Sync in the "Locations panel on left. Then re-do it. You’ll be asked for the password for access to the “server machine”.

  • On the iPad, go to the Sync settings, press the Edit button, then the red delete button. Then re-do it. Like the MacBook, you’ll be asked for the password for access to the “server machine”

Repeating past advice, re-read and do exactly as documented in the “DEVONthink Manual” supplemented by Bonjour Simplified. Nothing in that document says anything about "resetting Bonjour password. There is no such thing. It’s the password for the device using the ID you wish to remotely wish to connect to via the Bonjour networking protocol.

My regrets for such a tardy reply, BlueFrog, but I am away and have literally been out of touch. I expect to be back home tomorrow (Friday) and will get back to work on all your good suggestions of the past few days. I’ll try my best to figure it on my own without bothering you further yet that I can’t guarantee. I do appreciate your sticking with me though!