Problem with Editing Bar: Link

Unfortunately, while reading a PDF, I clicked on “Link” in the Editing Bar (instead of “Highlight”).

I cannot undo this, clicking on “Link” again does not change anything.

In this situation, trying to load another PDF in the same Tab didnot work.
Opening a new Tab and trying to load the first (or another) PDF did not work, either.

After quitting and restarting DT3, I could reproduce the problem with the “Link” button, but I was then able to load another PDF, switch back to the original one and use this procedure to get rid of the marked links.

In addition, displaying the links in PDF in the present way with gray stripes is not convenient for me. It makes the PDF more or less useless for me, as I need to read the names of the cited authors.

I am using DT 3.0 beta 4.

Thank you for looking into this.

The Annotation Selection mode is automatically enabled after using an annotation, in this mode invisible link annotations are marked. Just switch to the Text Selection mode again (see Tools > Mode or editing bar)