Public Beta 5: the Sorter ate my files & they're gone

This is DevonThink Pro Office.

I had seven folders containing about 20 PDFs and text files all told - nothing very big, no unusual file extensions, no unusual permissions on any of the files. Dropped these 7 folders into the global Inbox inside the sorter, and that has been the last I’ve seen of them.

The sorter still shows the number “7” next to the Inbox, but nothing shows inside DevonThink’s global Inbox. Clicking on the Inbox in the sorter produces the message “Operation could not be completed. Permission denied.” The message has an additional button marked “Go to Finder” that promises “Allow access to the folder contents using the Finder,” but this merely leads to a series of repetitively named empty folders in ~/Library/Application Support/ DevonThink Sorter/Global Inbox". I can recognize the folder name being used over and over (each time I click the “Go to Finder” button when I get the error message) as being one of the folder names I had attempted to drop into the Sorter.

I am going to turn off the Sorter for good and go back to the old way of importing documents by copying. Not so convenient, less damage.

Update: I found my folders & files in the Trash. Evidentally when the Sorter burped it pushed them into there.

The Sorter is still staying turned off - can’t be trusted.

I dropped by this morning to add a new topic regarding the Sorter, but Usable_Thought’s problem is similar enough to mine that I thought I’d include it here:

Dropping highlighted text from Safari beta 4 onto the Sorter results in an error box with the following text:


Both cases above sound like a Sharing & Permissions error on the user’s computer. The user isn’t authorized to save, modify or delete files in a certain location, so DT Pro/Office 2 cannot write the files to disk.

OS X maintains a system of access controls on files. Normally you, as the User, have authority to read & write to files and folders inside your User Library. When you are running an application that needs to write data into your User Library, you are letting it do so under your read & write permissions.

If Sharing & Permissions errors develop on a computer, strange things start to happen. You should, for example, be able to delete applications from the Applications folder, or files in your Documents folder. You can examine the Sharing & Permissions status, e.g., of a word processsor file in Documents, by selecting that file in the Finder and opening the Info panel (Command-I). Near the bottom of the Info panel, Sharing & Permissions should indicate that Username (Me) – you, the user – have read & write permissions. But if you are not listed as the user, or if you are listed but don’t have read & write permissions, there’s a problem. If you select that word processor file and attempt to delete it, OS X will instead require you to enter the administrative password first. You were not recognized as the ‘owner’ of that document, and must evidence additional authority as the ‘owner’ of the computer. Otherwise, deletion of that file won’t happen. Similarly, if you try to save a file into a folder for which you lack read & write permissions, there’s a problem. You don’t have authority to write into that folder, nor can an application you are running write into that folder.

To put it in the simplest terms, your computer is frakked. Why did that happen? I don’t know. But there is a way to edit Sharing & Permissions errors for a file or folder when they occur. (However, please don’t run amok and edit all the files on your computer to change Sharing & Permissions. There are many files that you shouldn’t monkey with, notably System files.)

Example: From time to time, users report that the Help > Install Add-ons procedure of DT Pro/Office fails to install some scripts. Following a run of that procedure, the Log will report the failure. Why did it fail? Because the user didn’t have read & write permissions for the folder into which those scripts should have been saved. The remedy is to select that folder in the Finder, open its Info panel, and correct Sharing & Permissions (it’s necessary to click on the Lock symbol and enter the administrative password). Perhaps the user isn’t listed as authorized. In that case, click on the ‘+’ button to add yourself. And/or the user is listed as having only read permission. In that case, change to read & write. Close the Info panel and run Install Add-ons once again. Now the scripts are available; DT Pro/Office was able to write them into the appropriate folder.

Something similar has likely happened when DT Pro/Office isn’t able to write files into the Global Inbox database and or Inbox, which are located within /Home/Library/Application Support/DEVOnthink Pro/Office 2/. There’s probably a Sharing & Permission error somewhere. I haven’t experienced this or seen a computer with this problem, so I don’t know where the error is. Start by checking Sharing & Permissions for the /Application Support/ folder, then drill down into its contained folders and files to identify where the problem is, and correct it.

First, I believe you are mistaken about the folder path for the Global Inbox. On my install it is “~/Library/Application Support/DevonThink Sorter/Global Inbox”.

And second, that path has no permission problems at all on my install.

The permission problems only begin within that path - that is, inside the Global Inbox folder - with the sequence of repetitively named folders I reported earlier. These folders did not exist until DevonThink created them. There is full access with all necessary permissions to the enclosing folder. There were no permission issues whatsoever with the folders or files that had been dropped into the Inbox.

So I think that (a) yes, there is a permissions problem - and (b) until proven otherwise, most likely it is a bug in the current version of DevonThink that caused it.

So it remains a product issue, not a user issue.

Sorry, I goofed, as I was thinking of the actual database file that’s the Global Inbox, which is in a different folder than /Application Support/DEVONthink Pro 2/Sorter/.

Sharing & Permissions errors of this kind are by no means limited to DEVONthink. They are occasionally encountered by a variety of applications, as I’ve observed in Apple forum discussions.

I can recall a permission error preventing installation of DT Pro scripts only once, three or four years ago, on one of my computers. Once corrected, the problem was solved, and I have no idea why that folder had changed from read & write to read only permission.

In any case, I’ve used the Sorter often, and it has worked properly, whether DTPO2 was running or not.

. . .and I realize now that I forgot to repair my permissions in Disk Utility or run OnyX afterwards, which in my experience is an absolute must-do.

I’ll run maintenance, inspect permissions, and test the PB5 Sorter again.

Just to be sure I ran Disk Utility. It found & corrected a permissions issue with /private/var/root - but since I don’t run DevonThink as root I would assume this is unrelated.

I can replicate the problem. It seems to occur with any folder being dropped into the Global Inbox. Is this a limitation by design - that the Global Inbox cannot accept folders?

Failing that, is there a safe way to reinstall?

Disk Utility doesn’t check the permissions of files inside home folders. At this point in time, your best bet would be to open Terminal, enter the commands:

ls -alFe@ ~/Library 
cd ~/Library
ls -alFRe@ Application\ Support

And send the results to

OK, I’ve run the commands & saved results to a text file, & sent that to Support.

I have clarified this in the support response but to make it clear to the general user populace: you should consider anything in the Application Folder off-limits for direct manipulation. Use the Sorter tab to drop things in there, or use the Finder’s Inbox that is available since public beta 5. Please do not drop files anywhere else because things will not work the way you expect it to otherwise.

Follow-up on my own post: it turns out that the Finder info files can cause problems when copying or moving whole folders into the Sorter. I’m going to check into that and fix it. In the meantime, using the our Inbox in the Finder is working fine.

More like to the minority of us who happen to be reading this thread. :slight_smile:

What’s a Finder info file? Are they any files that have a xattr?

A.k.a. “.DS_Store” much loved by Windows file systems…

Ohhh, those pesky files. :wink:

Maybe they’ll eventually be superseded by xattr’s, created when necessary for compatibility reasons similar to AppleDouble “._” prefixed files. Spotlight (Finder) Comments are saved in on Leopard so storing them in .DS_Store is already redundant there.

I just upgraded from DTPro 1 to ver 2, and find the sorter does not work at all. When I drag a selection of text to it, it pings, as if it has received something, or even sometimes showed a number designating the number of items it held. It got up to three once. But then when I return to it, nothing is there. More recently, immediately after dragging a selection to it, the inbox shows empty.

This is how it functions after DT Pro has installed itself. Sorry, but I as an ordinary user shouldn’t have to be figuring out how to root thru all my files and folders figuring out unix permissions. The Sorter should be storing its contents in a place where it has permission to do so.

My conclusion is that the Sorter is at this point completely disfunctional, as installed for the ordinary user by DevonTechnologies. I’ve stopped using it altogether. It simply does not work.



I think what you just described is how the Sorter is supposed to work. When DEVONthink Pro is running and the databases that the Sorter boxes refer to are available, the material will be moved into it automatically after a short delay without you having to root through anything. Have you checked your database to see that the information is there?

MTO, by default new content is being sent to the Global Inbox, which is a new database not found in DTPO 1.x.

The Global Inbox is displayed in the left sidebar of your database view window, which can be made visible by choosing View > Show Sidebar (there’s also a keyboard shortcut for showing/hiding the Sidebar.

You will find your files there. They are not gone, and you don’t have to root around for them.

See Preferences > Import - Destination. You might wish to experiment with the other user-selectable options, such as ‘Select group’.