Question about Files.noindex and auto importing

Few days ago, when 2.0 of DT pro went live (from beta) I decided its time to get a license and jump in the water, to see if I can swim.

Everything went smooth, I got a hang of tags, groups etc. I’ve imported several hundred Mb’s of documents during couple of days, sorting various ‘to be sorted’ folders that accumulated over past months.
Roughly at that point, I decided it would be faster if I just copy whole partial libraries (think various attempts to organize filed trough folder structured, few different such folders worth couple of Gb’s).

I dug deeper into instructions and help files, read about inbox folder hiding in ~/Library/Application Support/DEVONthink Pro 2/Inbox and figured it would be interesting to actually just throw stuff into DTpro and sort it later.

I threw several files, pdfs, various UI screenshots etc and code snipplets into this Inbox folders and watched with delight as files got sucked into DTpro. As initial tests worked, I figured it was time to go heavy lifting and threw next batch of files into Inbox. Roughly 500Mb large folder of semi structured batch of files landed in this Inbox folder and than I swapped my attention to other tasks.

After a while, must have been half an hour later or so, DTpro was still hard at work, copying those filed in, according to Activity Monitor, it seemed a bit odd as it was roughly 500Mb that I added into Inbox folder.

It was a that point that I had to change open and change something in one .ai file and upon starting Illustrator (trough Quicksilver) I got greeted with a dialog window, letting me know that Illustrator was moved, weather I want to try to fix it or quit. This caught my attention immediately as I didn’t move it myself.

Next thing you know, I was looking for place where Illustrator was starting from and much to my shock and surprise it was neatly filed inside Inbox.dtBase2 (Inbox.dtBase2/Files.noindex/app/f/Adobe Illustrator I wasn’t sure what was going on and figured it must be some sort of symbolic link, so I dug a bit deeper.

It turned out that somehow, and this is a point where I’m trying to ask for some insight, most of my /Appications folder was neatly moved into this Files.noindex folder inside Inbox.dtBase2 (/Library/Application Support/DEVONthink Pro 2/Inbox.dtBase2). Upon checking the size of otherwise empty (empty as far as I can see in DTpro, as all my files were moved into different database I created) inbox, showed me roughly 11Gb of data was stored inside this Files.noindex folder neatly stored in folders in range of 201 folders each named after file type that was stored inside.

What I would like to ask, if anyone can shed some light into how this came to be. Did I turn some wrong switch in preferences (only thing I seem to recall doing is that I told DTpro to directly import to my database not to Inbox database, when I import files).

I’m eager to use DTpro and organize abundance of various UI screenshots I accumulated over the years, and all other files, but at the same time, feel a tad bit weary at this point as it took me couple of hours to restore all files back to /Applications from Time machine backup.

Just in case I also made disk image of that Files.noindex folder, should it prove to be any help in uncovering this mystery for me.

I would like to ask for help, anything you can hint at, anything that might lead to import of all those applications, settings, sample files etc. I’m quite sure I didn’t drag /Applications folder to the inbox and any given time. All I remember is dropping that roughly 500Mb large folder with tons of files in Inbox and roughly half an hour later I ran into Illustrator app that was moved.

Stuff moved/copied to the Inbox folder is usally moved to the global inbox database. Is it possible that the dropped folder contained an alias or symbolic link or hard link to /Applications?

But even then this shouldn’t happen, e.g. moving an alias to the inbox folder copies the original file and removes the alias, I’ve just checked this again.

Sadly I must confirm this bug - its definitly DTPro who caused this shit.

I took a quick look to the systemlogs and alot of entrys from dtpro there
and mdsworker.

The symptomps are EXACTLY what the threadstarter described. I added nothing from Applications folder, instead it was the downloadsfolder. After
AGES it took for that 700mb ALL my applications that I had installed were
moved!! Only standardapps like e. g. Safari where still in place. For gods sake I had TM-backup.

BTW: there IS a hardlink in the downloads folder (by “accident” I unzipped Dropbox and that contains in its “installationdirectory” the link to applications.

Anyway: dtpro is to blame, hands down. I Know what I did and as you already mentioned: it shouldnt happen. But fact is: it did. In dtpro Pb8 all worked flawlessly.

To be honest, now I feel scared to use dtpro. It robbed me 4 hours for the backup and Research what happend. Imagines of I had not an actual backup.

PPS: and before I forget, Yes, my applicationsupport was also suddenly 11GB, with all my apps now moved to the inbox.
I wish I could go back to Dtpro PB8. This bug must be localized ASAP, although you don’t lose data, for me I had so many important things to do and now I wasted so much Time with this shit. I’m a coder myself so I know
that such shit can happen - but now with 2 people reporting same shit… just
believe me, I was fully aware of what I had to do and how. I can asure you: it was not a problem between chair and Keyboard. Please fix this ASAP

not related to this bug - but I really must ask who invented the
-sorry to nail it down to this - idiotic upgrade-process?

As DTPro (as mentioned above) moved most of my Apps to its inbox I started all from a backup. That backup still contained the PB8 version.

Now the funny part: After I started DT Pro PB8, it told me to upgrade as my
version isnt valid anymore (since 28.02.) and that I should download it from
the website, because (dont laugh) I MISSED THE DATE TO UPGRADE IT VIA

Serious guys - what is wrong here? Why cant I upgrade using DT Pro? No, I’m forced
to do it manual. Those, you need to e.g. shutdown the sorterhelper and some
other shit that normally shouldnt bother me - I mean, what is that upgrade-function used for?

I then adjusted the system-time to 7.2.2010 and (because I was curious)
believe it or not: Now it wasnt a problem anymore! DT Pro PB8 updated itself to latest final. I was speechless!

Really, I’m a fan of your softwareproducts but such nonsense should be avoided. Maybe I’m a bit harsh here but after 6 hours waiting of my restore, some missing files etc etc I’m in a not so good mood anymore, I hope
its understandable

You’re unfortunately right, the next release will add a workaround for this special case. In the meantime don’t drop folders containing aliases to /Applications to the inbox in the Finder’s sidebar. Or as the intended main purpose of the inbox in the Finder’s sidebar is actually to use it in save dialogs, drop only documents for now.