removing an element from a searchlist

Looked up some items in DTPO. Spotted one that should not be in there and tried to delete it. Deletion from a search list is disabled. I could tag it with “remove”; go to tags; find this single item quickly and remove it from there, but this seems a bit overdone.

Is there a quicker way?

See Deleting items in a smart group/folder

So can I conclude entering something in the search form (top right of main window) produces a smart group?

Funny thing is I cannot do delete, ctrl-click doesn’t show a delete option, delete button is grayed out, etc etc.

When I press shift-Apple-F I get a popup. Searching for the same item seems to produce the same list. However when I select “my” item ffrom this list the ‘delete icon’ becomes active. However still no reaction to control-cick, delete, etc.

Was hoping for a simple presss delete key to make this work. Any suggestions?

No. This does not create a Smart Group. It merely does a search on the active database. The Advanced Find can search all open databases.

You can right-click and choose “Move All Instances to Trash”.

I think it’s a better policy to make it a little harder to delete something, than to make it too easy.