Reset Encryption Key on Sync Store?

I’m still struggling with getting sync to work properly across two Macs, an iPhone, and iPad. A few months ago I switched from iCloud to Dropbox for the sync store, but sync still has issues. Items added on one device do not appear on other devices, although all (most?) of the older content appears on all devices.

It’s very possible that I’m not using the same encryption key across all these devices! I have not tried to find the actual key being used on each device.

So I have a few questions…

  1. Is it even possible to connect to one sync store from multiple devices using different encryption keys?

  2. What’s the simplest way to force a new encryption key on each device?

  3. If I change the encryption key for the sync store on each device, what’s the risk of data loss?

Thanks in advance for any light you can shed!

See e.g. DEVONtechnologies | Understanding Encryption in Sync

1 Like

Very helpful, thanks.

Ok, I think I followed the instructions in Jim’s excellent document, but I’m having mixed results.

After “cleaning” I set a new encryption key, then resumed sync on the “primary” iMac.

On the laptop I set the same encryption key, and the sync looks like it’s going well.

But on the iPad, after changing the encryption key, I now get a persistent error “Invalid encryption key”.

I use 1Password on all these devices and I am certain I’m using the correct key on the iPad.

Thoughts or suggestions?



1 Like

Are you using 1P to enter the encryption key or typing it manually?

I copy from 1Password, then paste into DTTG.

Ok, I typed the password into DTTG manually, with the same result. Here are the steps I followed:

  • Settings > Sync Locations > select Dropbox
  • Turn off sync with the toggle control
  • Tap Edit, then tap Edit on the next screen
  • Delete the two copies of the encryption key
  • Manually enter the key shown in 1Password (twice)
  • Save
  • Re-enable sync with the toggle control

After doing all this, I once again receive the “Invalid encrption key” error.

In case it matters, I have a 17 character key with lower and upper case letters, numbers, and special characters.



On the iPad, in DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket. Thanks!

Done, thank you!

You’re welcome :slight_smile:

Jim, I’m happy to say that pointing DTTG to the correct sync store solved the problem! :grimacing:

Thanks very much for your help!



You’re very welcome :slight_smile: