Results do not reflect search terms?

Maybe it’s just me being dense …

My query is

(vollmer NEAR sprenger) AND (management OR leadership OR führung OR business OR menschen)

First ranked result contains only the term “business”.

What am I not getting?

What’s the URL of this result and which search set or plugin did you use?

Search set: Customized Web (Deeper) with

  • Secondary query: -warenkorb
  • Excluded domains: .amazon., .abebooks.

Result URL:

If you specify a secondary query, then this query is used to match the pages whereas the primary query is only used to start the search.

Thanks Christian!

I see. Still makes me wonder: In my view, a result containing only a terms from the parenthesized OR clause is no valid result in the forst place.

For reference:

Because most search engines don’t support NEAR, you through the other clause at them?

When I am trying to understand how Agent works here, I would have thought that X NEAR Y would be translated to X AND Y or at least +X +Y.

Then again, given the dismal support for proper search in today’s search engines, does Agent flatten the whole query to somethink like:

I understand you have to work with what you get from Google and Co. But is there not a better way to optimize this?

Thanks & sorry

Did you remove or change the secondary query? Otherwise the primary query and all its operators don’t matter.

Sorry Christian, I believe I stated my issue in a confusing way. Please let me rephrase.

  • I search with Web (Deeper) for

(vollmer NEAR sprenger) AND (management OR leadership OR führung OR business OR menschen)

PS. The secondary query I used earlier was -warenkorb, which does match the page since it does not contain the term warenkorb - so that’s fine.

A screenshot of the Search window showing the “Settings” tab would be useful so that both the primary and secondary query are visible. Because…

…specifying a secondary query -warenkorb means that all pages not containing warenkorb are accepted - the primary query doesn’t matter.

Here you go.

Weird. I just used the same settings but the website isn’t accepted. Then I created a new search set, set the above primary query and added the website to the “Sites” tab. And once again the page isn’t returned as expected.

Could you save a search via File > Save As…, zip the saved search and send it to cgrunenberg - at - Thanks in advance! Finally, which version do you use?

Thanks Christian!

Might take me until Thursday :frowning:


I tried to replicate my search to generate a shareable result file. And this time, no Times of Malta.

Either there really is a glitch in DA, or we’re dealing with PEBKAC. I tend to consider the latter.

Sorry. In case I will come across something like this again, I’ll let you know.