'rtf' documents showing as... something I don't know what format is

It just happened:

  1. I opened one ‘rtf’ document and it opened in a “weird coding”,

  2. so I deleted the “weird text in code” and replace it with the text I wanted, and

  3. then… misfortune happened: now almost all the 'rtf’s documents are opening in this “weird code format”.

Also, the ‘rtf’ files don’t seem to open directly within DT, but it open with the mac’s ‘TextEdit’, without the DT’s menus.

I am attaching an example image of the way ‘rtf’ documents now open.

I use ‘rtf’ documents quite a lot and I siht myself quite a bit with this issue.

Please help

What you are seeing is the way rich text documents are encoded, when you open them in a plain text editor. Here is an example:

The original rtf contained: “Chess stamps Austria and others” (with Chess stamps in a bigger, bold font)

\cocoatextscaling0\cocoaplatform0{\fonttbl\f0\fnil\fcharset0 Morandi-Regular;}

\f0\b\fs48 \cf2 \expnd0\expndtw0\kerning0
\outl0\strokewidth0 \strokec2 Chess stamps

\b0\fs24 \cf2 Austria and others

What might be happening is Finder is opening rtf documents as plain text.
In the desktop, select any rtf file, click Command-I to open the file info, then look at the “Open with” menu - what application does it say will open this kind of file? It should say “TextEdit.app”. You may have it set as something else, like BBEdit, or some other plain text app. If so, just change to “TextEdit” and confirm to open ALL files of the type (rtf) with TextEdit.

Thank you so much for the response! It helps me to understand what that weird code is.

So… I used to double-click on the ‘rtf’ documents and they opened with some kind of DT’s “text editor” (with menus and all). Now If I have to right-click and ‘open’ the document - to get that DT’s “text editor” (with the menus and all). I don’t know why this sudden change.

Now when I double-click the ‘rtf’ documents - they open with the system’s default app. ‘TextEdit’ just opens ‘rtf’ documents with all the coding (idk why). So I got the app ‘RTF Write’ and documents open just fine.

Does this happen when you open the rtfs in the Finder itself? (not in DT) - You double click and they open showing all the rtf code?

Did you read the info file to see the default app for them?

So: the rtfs open in Finder with the code with ‘TextEdit’ (but no code with ‘RTF Write’).

I have not read into the file, bc I do not understand the language of files :sweat_smile: but now the default ‘rtf’ editor is ‘RTF Write’.

I have found though the checkmark option: ‘double-click opens documents externally’ < ‘interface’ < ‘general’ < ‘preferences’

Now documents open within DT when double-clicked

Are you running the macOS Ventura beta or made any other upgrades to the machine prior to this issue occurring?

nueva, can you please open the preferences for the application ‘TextEdit’? I am attaching a screenshot of mine here. Can you see how the settings in mine say “Format Use the Format menu to choose settings for an open document” - is yours set to “Rich text”?

my system says that is running ‘macOS Monterrey 12.5’, and I keep the computer updated at the computer’s will

the error happened “randomly”, I don’t think it has to do with updating the OS

Yes, it is set for ‘RTF’ :man_shrugging: I am attaching an image of my settings on ‘TextEdit’

‘TextEdit’ keeps on opening ‘rtf’ files with code, it must be an issue with ‘TextEdit’. I am attaching an imagine of the code that display, what’s the technical name for this code?

ps: the support in this forum is very encouraging :+1:

1 Like

What you have posted is the sort of thing I see if I open an .rtf file in an application which for some reason displays the codes in an .rtf file (for example, CotEditor). However if I open the same file in TextEdit it will display perfectly (i.e., without showing any codes).

Try taking a look at this Apple support article to see if it helps.


1 Like

RTF. That is RTF: a text format that is interpreted by a program (usually). Of the program does not know how to do that, it’ll simply display the text as it is. Or nothing at all, perhaps.

1 Like

That’s what we like to hear, so thank you! :heart: :slight_smile:

  • Regarding the RTF files, does this happen with all the files you open in TextEdit or a handful?
    • If a handful, is there anything specifically different about them, e.g., where they were made or stored?

It happens to almost all the ‘rtf’ files, I don’t know what to make out of it

A screenshot of the second tab of the preferences would be useful, most likely the option to load the raw RTF code is enabled.

Ahh… good call.

In TextEdit’s Preferences > Open and Save

That’s exactly what it was! :slightly_smiling_face: The ‘display RTD files as RTF code instead of formatted text’ < ‘open and save’ < ‘preferences’ < ‘TextEdit’

Thank you for your help!

You’re welcome though the credit goes to @cgrunenberg for the suggestion. I just illustrated it :wink:

1 Like