RTF Memo service creates wrong source URL

I just added a text portion from a web site in Safari to DEVONthink Pro Office by using the context menu and in the services New RTF Memo.

I don’t do this very often so I wasn’t sure if this method adds the URL of the text snippet too. Because of that I checked DEVONthink’s info window of named snippet and to my surprise it contained either the right URL or plainly nothing but the URL of the item before the snippet, which I had added one or two days earlier. Bug, I’d say.

I have to wonder if you actually captured a new snippet in DEVONthink, as there is no DEVONthink Services menu command ‘New RTF Memo’.

FWIW, I use the DEVONthink Services menu commands ‘Take Rich Note’ and ‘Take Plain Note’ multiple times every day and I always get the correct URL added to the note.

The fact that I use DEVONthink with a German UI and the chance that my re-translation of the context menu item name to English did not exactly match its real English name might have caused a little confusion.

But I think we are talking about the same thing:

Context menu item “Dienste” is “Services”:


And “Neues RTF-Memo” is “Take Rich Note”:


I have just tried using this service again—and this time it worked flawlessly. A few hours ago it did not and more than just once. So it is an erratic bug.

Are there any known interferences with TextSoap/TextSoap agent? That’s the only app I have running that is using the clip board beyond the normal copy&paste. Just a thought.

Yes, the translation to German would explain the name difference in the Services menu.

As to a possible conflict with TextSoap, I have no idea. As I mentioned earlier, this Service menu item has always worked fine for me. I do use LaunchBar, which also manipulates the clipboard, but they appear to work fine together. Perhaps others might check in with some thoughts/suggestions.